Categories: Setting up your device : Nexus 4 :

4.4.2 update error

Showing 1-101 of 101 messages
4.4.2 update error Plunkett McGreevy 12/9/13 3:18 PM
When attempting to install the OTA update file for 4.4.2 (approximately 50MB as I did not receive 4.4.1 OTA), I get an error message. The  installation progress bar gets to about 20 per cent, then freezes and then I get an error message - android with open stomach icon.

I do not have a PC & should not have to sideload a zip file or root my phone to access this update. Please advise how this can be remedied in the least obtrusive & most direct manner possible.

Thank you.

4.4.2 update error Tony Ji 12/9/13 4:24 PM
The exactly same thing happened to me... Downloading is fine but after rebooting and installing for 20 percents it is stuck and said error! Mine is nexus 7 2013. Don't know why,,, hope there is a solution!
Re: 4.4.2 update error Tony Ji 12/9/13 8:34 PM
I can't even get a notification of update now...."Your system is up to date"...

Ughhhhhhhh
Re: 4.4.2 update error Keith Bender 12/9/13 11:43 PM
Same here man :/
Re: 4.4.2 update error Luka Sajovic 12/10/13 1:15 AM
I have the same problem
Re: 4.4.2 update error Anas AbuDayah 12/10/13 1:41 AM
I have nexus 4 running on kitkat 4.4 and after download (via OTA) the new updates and reboot the device, my nexus 4 freezed and show me "error" with warning icon.. I repeated this and I got the same error!
Re: 4.4.2 update error Plunkett McGreevy 12/10/13 3:10 AM
Over to you Google. FAOD I am running stock 4.4, unrooted.
4.4.2 update error Jock Farrington 12/10/13 4:51 AM
Yeah same thing here. Tried side loading the update as well but still get an error.

Nexus 4 on 4.4

Re: 4.4.2 update error Keith Bender 12/10/13 12:54 PM
I figured it out! We all have something flashed on our nexus 4's that isnt stock, most likely a root?... but like with me i had a hybrid .33 and .97 radio flashed... so when the phone would try to update it got an error because it didnt recognize the files.....

to fix this you have to take the 4.4 stock roms file components, in my case the stock .97 radio..and flash it over again via fastboot... and im currently sideloading the 4.4.2 update... and it succeeded 
Re: 4.4.2 update error Tony Ji 12/10/13 1:05 PM
When my Nexus 7 is still 4.3 I rooted it but didn't change system files. I tried upgrading it to 4.4 and it succeeded, then I lost my root. 

So it should still be working with this update again, since it's just a 0.02 update. In fact I'm also hesitating that a not clean base system with root history might really get some trouble with the update.

Flashing is okay for me...But I need to back up data and do other stuff, which is really boring. :(

What's the big difference in 4.4.2? If not much I may well not do it for now.
Re: 4.4.2 update error Javier de Pablo 12/10/13 4:23 PM
No modification on Nexus 4 still same error as descibed above...
Re: 4.4.2 update error Keith Bender 12/10/13 5:58 PM
Yeah i see where your getting at, but with sideloading you wouldnt have to backup anything up

But dang Javier i dont know what it could be :/ it has to be something that modifies with the stock roms files that it doesn't recognize....try sideloading it, and the error message should tell you whats wrong
Re: 4.4.2 update error vivs 12/10/13 9:43 PM

My nexus 4 phone says couldn't download 52.0 MB Android 4.4.2 System Update (please see the snapshot below). I tried it both on data connection as well as on wi-fi. Clicking "Retry download" does nothing. I also tried restarting the phone, but no result :(. Please help. 



4.4.2 update error SAMRAT KULKARNI 12/10/13 10:33 PM
Hi Google.
I am also facing the same issue like my fellow friends.
Please help us asap.

My device is useless from last 2weeks
After KitKat update.

Or at least help us to roll back to 4.3

Re: 4.4.2 update error JoGiMon 12/11/13 3:24 AM
Same here. Unrooted nexus 4. Now showing: "your system is up to date" X(
Re: 4.4.2 update error Javier de Pablo 12/11/13 8:24 AM
Hey! I tried sideloading too, same result. I guess we'll just have to wait for a fix.
Re: 4.4.2 update error Tony Ji 12/11/13 8:27 AM
Too bad. Hopefully Google will notice this and come up with a fix. 4.4.2 is mainly for Nexus 5 I think. Its already great that we can get a notification...
Re: 4.4.2 update error Garen Loshkajian 12/11/13 10:29 AM
My brother's Nexus 7 2012 does not have this issue at all.
Re: 4.4.2 update error Andyyo 12/11/13 10:57 AM
I am having the exact same issue but I have a Nexus 5. I have tried the OTA update 10 times or so and get to about 20 percent. I even reset to factory defaults before doing it a couple times. Stock android never rooted has phone for like a month.
Re: 4.4.2 update error Jock Farrington 12/11/13 2:46 PM
Okay so I found my problem.  My radio or modem was the wrong version .84 instead of .97 even though I have never flashed an alternative radio to stock?

I then re-flashed the whole 4.4 stock image again and checked the radio which had now changed to .97.  Not long after setting up the phone I got an ota update message for 4.4.2.  This time it installed no problems.

Jock
Re: 4.4.2 update error Tony Ji 12/11/13 2:54 PM
How do you check your radio version? Never heard about it
Re: 4.4.2 update error Javier de Pablo 12/11/13 2:57 PM
Settings about phone baseband version. Not my problem though, I have version.97
Re: 4.4.2 update error etolini 12/11/13 3:21 PM
same... stock device, 4.4, retar via ota for install update and android died... can start te phone but all sistem crash, only see errors and can't do nothing.
Re: 4.4.2 update error SAMRAT KULKARNI 12/11/13 10:44 PM
Hey Google.
Can we get help.....
Now this very annoying...
We are really running out of patience.
Please give us some solution.
Re: 4.4.2 update error Javier de Pablo 12/12/13 7:48 AM
We're only 13 people, I have a feeling we're going to have to sit tight until 4.4.3 comes out.
Re: 4.4.2 update error Plunkett McGreevy 12/12/13 7:51 AM
True but some sort of acknowledgement from Google would be nice. Even if it is 'noted, we are looking at this' or 'have you considered doing xy or z?'.

What is the point of product forums otherwise? Surely it has to be for something other than solving low hanging technical queries?  

Re: 4.4.2 update error SAMRAT KULKARNI 12/12/13 7:54 AM
Absolutely right I too feel the same.
Re: 4.4.2 update error Javier de Pablo 12/12/13 7:54 AM
I completely agree and hope we get some kind of response sooner or later.
Re: 4.4.2 update error Greg Marshall 101 12/12/13 3:08 PM
Same problem, stock Nexus 4 not rooted...
Re: 4.4.2 update error Greg Marshall 101 12/12/13 3:08 PM
Re: 4.4.2 update error Farhat Masood 12/12/13 6:26 PM
Or maybe what just triggered this error was custom kernel? I am using Stock 4.4 which was updated OTA but then I rooted the device and installed custom kernel. Maybe that is resulting into error. I just came across this error 5 minutes ago. Will sideload 4.4.2 hopefully.
Re: 4.4.2 update error Mike Santillan 12/13/13 12:33 AM
Getting the same issue on my n5. Even went so far as to do a factory reset, but I'm still getting the android operation error screen during the 4.4.2 update.
Re: 4.4.2 update error Mike Santillan 12/13/13 12:33 AM
Re: 4.4.2 update error raja gunasekaran 12/13/13 12:45 AM
Hi,
I too have the same problem!!! Would love it if someone know how to update to 4.4.2. Mine is unrooted nexus 4 with stock 4.4 try to update to 4.4.2. my base band is also .97


Thanks
Re: 4.4.2 update error Đức Hùng Phùng 12/13/13 4:15 AM
i have same error
Re: 4.4.2 update error Đức Hùng Phùng 12/13/13 4:15 AM
i have same error
Re: 4.4.2 update error SAMRAT KULKARNI 12/13/13 7:23 AM
Hi Friends,
I have successfully re installed kitkat 4.4, and now my cell is working fine.
follow below link for you reference.


if u have any further query i will try to help.


Thank you.  
Re: 4.4.2 update error tavi 04 12/13/13 8:36 AM
Same problem for me.
Re: 4.4.2 update error Greg Marshall 101 12/13/13 8:57 AM
Hi,  we're talking about issues installing 4.4.2 not 4.4
Re: 4.4.2 update error SAMRAT KULKARNI 12/13/13 9:35 AM
Hi,

This is for 2 issues :- 1) for people having prob since 4.4 update & 2) for people having error updating to 4.4.2

You can repeat the same process mentioned in the video from previous link & flash  4.4.2 downloaded from below link:

Dont forget to check ur built number. Mine was KRT16S  for 4,4

Thanx

Re: 4.4.2 update error Farhat Masood 12/13/13 10:11 AM
Finally I am through the update. 
Unlocked by Bootloader
Un Rooted the device
Installed the stock kernel
locked my bootloader

factory reset

And then I got the update available notification with 52 Mb size. And it happened without a trouble.
Since, there is no fun without root, so I am planning to re-root my device on 4.4.2 but OTA might fail again.

Chris Brown2404 12/13/13 2:31 PM <This message has been deleted.>
Chris Brown2404 12/13/13 2:34 PM <This message has been deleted.>
Re: 4.4.2 update error Chris Brown2404 12/13/13 2:34 PM
I also get an error whole updating to 4.4.2 from 4.4. My phone is NOT rooted and has only been updated via OTA this issue is not related to root problems!!
Re: 4.4.2 update error Shaheryar Rafiq 12/13/13 8:53 PM
You mean unroot first, Then install update auto.?
Or
Without unrooting can I sideload 4.4.2 update from google site?
Re: 4.4.2 update error Amit Deshmukh 12/14/13 3:18 AM
Let's take a very safe approach here:

1. Let's start the phone in safe mode. To do this press power button and when u get Power Off option, long press the power off on screen and you will get the safe mode.
2. Go to settings --> Apps --> All Running --> Google Framework Services and clear data first then force close. That's it, don't click on anything else.

Your update should start. If not, open your key pad and press *#*#CHECKIN#*#*. This should trigger your update. Have fun.

//A

Re: 4.4.2 update error Plunkett McGreevy 12/14/13 10:23 AM
Just bit the bullet & sorted this out. I unlocked the bootloader, wiped the phone and flashed the 4.4.2 factory image & radio.

All working OK now but would have preferred not having to wipe my phone.

4.4.2 update error RbN.. 12/15/13 1:37 AM
I am running android 4.4 krt16s on my nexus 4. I had received ota before and it succeeded without any error. But when i tried to install ota for 4.4.2 it shows a similar error as mentioned above. I am running stock android unrooted my bootloader is unlocked.
4.4.2 update error RbN.. 12/15/13 1:37 AM
4.4.2 update error RbN.. 12/15/13 1:38 AM
Re: 4.4.2 update error Frederik Schmeisser 12/15/13 2:56 AM
Hi

had the same problem

fixed it by updating my rado/baseband from .84 to .97 then i updated by sideload

hope it works for you

Freddy
Re: 4.4.2 update error Ewan Gubbins 12/15/13 7:02 PM
Hey, this worked as far as 30% of the way through the update, then came up with the error again. Nice try though.

Cheers.
Re: 4.4.2 update error Regan Yee 12/15/13 9:43 PM
Seems like lots of people are having issues.  Just wanted to say I downloaded 4.4.2 ota straight from Google no sidwload and had no issues.  I was having exchange issues with 4.4 and did not get 4.4.1 before hand.  Everything seems to work just as it should.  No camera issues and glad to say exchange is working finally.  Hope you guys get it installed cuz it definitely fixed my problems.  And I'm running a nexus 4.  Hopefully nexus 5 come Xmas.

Good luck to you all.

Regan Yee 12/15/13 9:43 PM <This message has been deleted.>
Re: 4.4.2 update error Vishnu Radhakrishnan 12/16/13 9:23 AM
if u r rooted and have removed any system files like downloader provider..may be some stock apps...then possibly your update is going to fail as it confirms update by checking the older versions ...something like that
Re: 4.4.2 update error Paul 12/16/13 1:54 PM
Hi folks, sorry I'm a little late to this thread.

As a few of you who have rooted/manually installed a version of Android on your phones, it sounds like a few of you are giving nice advice to each other. I'm afraid I can't provide further assistance in that scenario.

If you've never rooted your phone or manually installed Android on your Nexus, but are still getting an error when your phone downloads the update, here are some suggestions:

1. Hold power button and select Power Off
2. With device off, hold Volume Down button and press power button. An image of an Android lying on its back will appear.
3. Press the Volume Down key twice until Recovery mode appears on the screen.
4. Press the Power key to restart in Recovery mode. An image of an Android with a red triangle will appear.
5. While holding down the Power key, tap the Volume Up key.
6. The Android System Recovery screen will appear. Release all keys.
7. Use the Volume keys to scroll to wipe data cache partition and press the Power key to select.
8. The device will restart.

If that is not successful, you can try a Factory Data Reset, but be aware this will erase all your personal data from internal storage. See instructions here:

If Recovery Mode is not available at all, you may need to RMA/exchange your device using the retailer from which you purchased it. If you purchased it on Google Play, please contact our live support.
Re: 4.4.2 update error Greg Marshall 101 12/16/13 2:14 PM
Hi Paul,

Tried all of the above, I have an un-rooted Nexus 4 that has only ever had the stock rom.  Factory reset, OTA update and side loading of 4.4.1 and 4.4.2 all fail....
Re: 4.4.2 update error mintslice 12/16/13 2:57 PM
My Nexus 7 is stock and I haven't ever rooted it.

The only non-standard thing on it is I've sideloaded the Google Experience Launcher.  I didn't think this was a huge issue because Google recently made changes to improve the experience on tablet devices and also because Google's security model checks sideloaded apps for issues which I would assume means any issues with the GEL would have been addressed.

So far each update up to and including 4.4 has worked fine.

I've had two OTA updates for 4.4.2 come in and they were already downloaded so all I needed to do was restart.  Each time they've got to around 20% and failed.

I've followed your instructions Paul (not including the factory reset, but I'm willing to try if you think it might work) but it's not offering any updates.

Should I try a factory reset, or is there more information I can give you?
Re: 4.4.2 update error Hristo Petkov 12/17/13 2:24 AM
Hi Paul, 

I did the same on my Nexus 5 and it did not work to me either. it Does not give me the new update either.. i am stuck on 4.4
Re: 4.4.2 update error Gareth Smith 12/17/13 3:20 AM
Having similar issues with a completely stock Nexus 7 (2012 mobile). Currently on KRT16S and every time it downloads the 4.4.2 update it stalls, shows the error screen defined above and then reboots. Trying to "request" the update from the settings menu says that it is up to date on 4.4

Reset cache partition does not cause the issue to go away. Currently backing up settings but shouldn't need to factory restore a stock device just to update it. Tempted to try a sideload of the update package to see if it gives any additional error information.
Re: 4.4.2 update error Lachlan Comb 12/17/13 5:37 AM
I bought a Nexus 7 2013 32GB a week ago and having the same issues. After the first time it failed the update at 20% I tried a factory reset and same problem. It looks like it came with JSS15J
Re: 4.4.2 update error Hristo Petkov 12/17/13 5:41 AM
Mine Nexus 5 is KRT16M .. so it seems a lot of devices are affected...Google should do something on this.. ASAP. 
Re: 4.4.2 update error JoGiMon 12/17/13 6:12 AM
I have an unrooted nexus 4. Same error. For every solution, there is a problem. Tried ADB sideload, tried wiping data cache partition, tried forcing the OTA and also Factory Data Reset.

In my case, when doing the ADB sideload this is the mesage on screen (hoping this could be a clue for someone):

....
Verifying current system...
"/ststem/priv-app/Velvet.apk" has unexpected contents.
E:Error in /tmp/update.zip
(Status7)
Installation aborted
Re: 4.4.2 update error Hristo Petkov 12/17/13 6:26 AM
So Paul..  you wanna say that there are so much defective devices out there which should be replaced???? I am sure that you are aware of how much topics you have on the forums about these issues.!! This does not sound good for Google devices ..don't you think????  Or just Google doesn't want to admit that there is big software issue with Kit Kat and the current updates (4.4.1 and 4.4.2) ???? Thanks for your time.. 
Re: 4.4.2 update error Ron Moody 12/17/13 3:48 PM
Hey Paul, thanks from Maui!

Ever since that last update, my 2012 Nexus 7 has been in landscape mode. I could reboot but it would quickly return to landscape. I have an app that runs in portrait mode, so I would switch to that, then to other apps I prefer in portrait. But if I moved much at all, it would return to portrait mode and stay there.

YOUR INSTRUCTIONS FIXED IT! Thank you so much. I was getting so frustrated. But I can actually use it again.

Thank you sir.
Ron from Maui
Re: 4.4.2 update error Ron Moody 12/17/13 7:21 PM
Spoke too soon. It lasted an hour or so. It's back to broken now. In Hawaii... "Stay broke".
ron
Re: 4.4.2 update error saranpande 12/20/13 4:09 AM
Exactly same case here,identical issues,please Google solve it as soon as possible
Re: 4.4.2 update error JoGiMon 12/20/13 8:44 AM
Fixed 4.4.2 on my N4 by downgrading to 4.3. Then OTA to 4.4 and 4.4.2, with no problem. But I still have the same 4.4 Exchange mail bug :-S
Re: 4.4.2 update error Hristo Petkov 12/21/13 11:06 AM
Hey guys, i did all what Paul suggested but it did not Help.
Then i decided to try manualy update to 4.4.2

when side-loaded the update to the phone..the installation started and here is what i am receiving:
------------------------------------------------
Finding update package...
Opening update package...
Verifying update package...
Installing update...
Verifying current system...
"/system/app/QuickOffice.apk" has unexpected contents. 
E:Error in /tmp/update.zip
(Status 7)
Instalation aborted.

-------------------------------------------------------------
It seems that the OTA installation give the same error but we cant view it when it is on Auto mode...

Paul, please provide what is Google view on this error???
A i said in my previous posts.. it cant be hardware issue.. but software one for sure.
Please advise how to fix this. I want my 4.4.2 update now!!!!
Re: 4.4.2 update error Hristo Petkov 12/21/13 1:26 PM
Hi all,

its me again.
 
From the last post its seems that there is something wrong with the QuickOffice .apk file installed on the original firmware.
That's why i did Force Stop->Disable on QuickOffice app and decided to sideload 4.4.2 update again
This time everything was OK and the update completed successfully (woohoo) :)
Reboot of the phone followed.

But here comes the bad thing.. the phone stuck on "Google" text boot logo... 
When get to the recovery mode (Holding Volume Down+Power button together) its clearly visible that the 4.4.2 (KOT49H) is now installed.

But the phone wont pass the "Google" text boot logo...
 HEEEEELLLPP!!!  :) :)


Please if you have some suggestions.. 
Re: 4.4.2 update error Hristo Petkov 12/21/13 4:54 PM
Hi all,

it's me again..

this time i have good news.. :) i am with 4.4.2 at last ! :)

.. Fresh Firmware installation worked.

i just want to tell you that the installation took less than 2 mins.. and is so easy.. :)

i hope i wont have the same issues with 4.4.3 ..

so ..again.. this is not HW issue as Paul explained.. its pure software issue..

Good luck to all !!!
4.4.2 update error rdmoore 12/22/13 12:23 PM
My Completely Stock Nexus 4 just tried to OTA KITKAT 4.2.2. During the update, when the blue polygon is inside the open hatch, it just stopped and presented a red triangle with Error! written below the triangle. I left it like that for 1/2 hour or so, then restarted the device. Now there is no longer notification of system update, about phone shows 4.4. Also says system up to date.

Damn.Otherwise, the phone seems to be working well just reporting.

4.4.2 update error rdmoore 12/22/13 12:23 PM
Re: 4.4.2 update error Greg Marshall 101 12/23/13 2:05 AM
I'm getting the following error whenever I try to sideload 4.3, 4.4.1 or 4.4.2:

E:Error in /tmp/update.zip
(Status 7)
Installation aborted

Come on Google - pull your finger out!
Re: 4.4.2 update error Hellek 12/24/13 8:00 AM
Hello Paul,

I tried your steps (clear cache; since that did not help also factory reset aka wipe /data through recovery menu). It did not help, I still get the error during update from 4.4 to 4.4.2. I hope you are looking into it and working on a fix. I never rooted my phone nor did I ever install anything through ADB. I always waited for the OTA. Very odd: my parents have the Nexus 4 too and they did not have any trouble. They live in Austria though, while I live in Germany and they got their phones a few months later than I did. That's the only differences that I am aware of.

Best regards
David

Re: 4.4.2 update error Gareth Smith 12/24/13 10:46 AM
Had a similar situation to Hristo following instructions to sideload the update except with my N7 (2012 mobile version) I got Gmail as having unexpected contents rather than QuickOffice

Now QuickOffice I could potentially understand a software conflict as I don't think it's a Google application but Gmail kind of takes the mickey slightly.

Clearly a software issue and has tried to update OTA once since still failing to the error (looks like a dead Android) screen, then a five minute pause to reboot.

Factory restore hasn't helped and I don't really want to do a full factory image restore to JDQ39.
Re: 4.4.2 update error Brian D. 12/27/13 10:58 AM
I'm having the same issue with an unrooted Nexus 4 running 4.4. I get the system update notification, reboot and apply, and it gets to about 20% and fails.

I contacted support and they pointed me to wiping cache, which I tried, still got the same error. Their next advice is a factory reset, but if all the folks in this thread have tried that and it hasn't fixed it, then I certainly don't want to wipe my device fruitlessly.

Hope Google resolves this with 4.4.3.
Re: 4.4.2 update error mintslice 12/27/13 11:19 PM
Hi Paul,

I've followed all your instructions now.

I've tried just clearing the cache and no luck

I've no tried a factory reset (and went so far as to not log into google's realm so that there was nothing on the device other the the base android) and still no luck.

I'm now up to 5 OTA updates - 4 of which have come through after a week of the last version - and one which came in straight after the factory reset.

I'm seeing this problem on Google+ (some seem to be pointing a the radio/modem update) but no one seems to have an answer, including Google.

I'm willing to work with you to try and resolve this, but a little more guidance would be great.

regards


mintslice
Re: 4.4.2 update error raja gunasekaran 12/31/13 1:36 AM
Hi,

Can someone tel me if this would work?
downloading the factory image of android 4.4.2 for nexus 4 from here which is 435mb and load it?
Will that work?

Thanks,
Raja
Re: 4.4.2 update error Jay Freeman 1/3/14 3:02 PM
I have a Nexus 4 that isn't rooted and has absolutely no modifications. I was experiencing the same problem as everyone else here.

After completing around 20% of the update, it fails and displays a dead android image.

I then cleared the cache and tried with no luck and then factory reset my phone as advised here with no luck, either.

In all I must have received around 8 or 9 notifications over the past month to update to 4.4.2, all of which have failed.

Surely this is worth looking at, Google?
Re: 4.4.2 update error Hristo Petkov 1/4/14 7:25 AM
Hi Raja,
yes this will surely help.. at least it worked for me :)
i did the same thing and now i am running 4.4.2 on my Nexus 5.

P.S. Google, i HOPE you are already working on these issues and the issues 4.4.2 has (rebooting, camera sometimes shown as not connected and etc.)
Re: 4.4.2 update error Joseph Richman 1/8/14 1:15 AM
It would seem this is caused by a version mismatch error. If you didn't get 4.4.1 you will NOT be able to upgrade directly to 4.4.2 since 4.4.2 OTA looks for the 4.4.1 signature as opposed to the 4.4 signature.

Solution?

updated to 4.4.1 first and then go to 4.4.2

4.4.1

4.4.2

It'd be a simple fix on Google's behalf to fix it, but faster to just run the files yourself.
Re: 4.4.2 update error Gareth Smith 1/8/14 2:37 AM
Intriguing Joseph, though you'd think that the server should be trying to push the correct update. I've never had 4.4.1 offered on my Nexus 7, only 4.4 as soon as it was available OTA and 4.4.2. For the purposes of OTA 4.4.1 seems to have been skipped on a lot of people's devices.

Wonder if Paul has any thoughts on this and whether Google are working on a solution.

Looking at this further the reason for this in my case is there was no 4.4.1 for Nexus 7 (2012, nakasig) devices. The 4.4.2 file will not sideload showing a mismatch message similar to the one detailed by Nexus 4 users (but most frequently for GMail). I've had about 14-15 push attempts on 4.4.2 since my post on 17th December and they all stall at 20% with the "dead" Android image. It then takes about 60-90 seconds before the device reboots. Clear cache and factory restore do not resolve the issue.
Re: 4.4.2 update error Joseph Richman 1/8/14 8:31 AM
Yea that sounds like it's failing the verification check, a simple way to check would be to (if you're unlocked) run a third party recovery temporarily and try installing the file that way, if gives a more detailed log of what's happening compared to stock recovery.

This is a list of OTA links for the Nexus 7 device, including a section for nakasig:

There are apparently 3 different upgrade paths to get to 4.4.2, one is from Jellybean, the other two are from the original 4.4 release (KRT16O) and then the immediate patch build (KRT16S)  (Note I may have those build designations backwards. The easiest way to find the correct one is to go into Settings > About Phone > Build Number and downloading the upgrade file for your build designation.

To be honest it feels like there were a lot of issues with Google's updates this time around, I'm not sure if it was a matter of them hiring new staff, or trying out a new system, but it seems like a lot of mistakes were made that shouldn't have been.
Re: 4.4.2 update error Gareth Smith 1/9/14 2:54 AM
Joseph,
Unfortunately that's what I've been trying using the KRT16S to KOT49H nakasig zip file. It still stalls at verification stage still with Gmail having unexpected contents.

The device has not been unlocked and while I was planning to do this at some point given the problems I am now having with stock updates I am loath to unlock the device until this is resolved. Also it seems from Paul's comment above that if you unlock Google will be washing their hands of you completely given the recent update issues (of their own causing).

All previous updates have been OTA and I've had the device since before 4.3 was released for the nakasig device. Given the number of times I've cleared all data on the device (again at the request of Paul above) I'm half tempted to reload the 4.2.2 factory image manually and see if it actually OTA updates from there especially if I could find some way to skip the Google set-up screens on a "fresh" device.

This and the lack of wireless hotspot is making me wish I hadn't moved away from my faithful brick of an original Samsung Galaxy Tab.
Re: 4.4.2 update error Joseph Richman 1/9/14 5:24 PM
Unfortunately, Google probably won't be a lot of help, since the Nexus 7 2012 edition has fallen out of it's "support" time frame. You'd have better luck reflashing your device (after unlocking) and upgrading it that way. The thing is, they screwed up the updates and don't want to have to admit as much, so they're saying they won't support people who have manually installed firmware.

For example on my Nexus 4 I had manually installed 4.3, it got the update to 4.4 just fine, it never got the update for 4.4.1 and since their 4.4.2 update looks for the 4.4.1 signature it refused to update. Clearly not an issue on my part as I was able to download the OTA's and run them in order to get it to working.

It's rather disappointing they'd rather opt to refuse support, rather than just fixing their own problems.

Re: 4.4.2 update error ozi keri 1/11/14 5:09 PM
I just can't believe the moto phones and other phones are prepped for 4.4.2 when they haven't even sorted out nexus devices!
Re: 4.4.2 update error David.Latapie 1/12/14 3:40 PM
Could you be more explicit ? I can't find it on my unrooted Nexus 4. Screenshots would help.
Re: 4.4.2 update error Diego Soto 1/15/14 5:54 PM

Re: 4.4.2 update error mintslice 1/18/14 10:30 PM
Hi Paul,

I'm still getting these failed updates.

I'm a little concerned as I'm hearing that Google may have dropped support from my Nexus 7 (2012) and I don't need to be spending the rest of it's working life (which should be some time) having to ignore updates that don't work.

I would assume Google is working hard on resolving this, but would appreciate some reassurance as you've posted once here and haven't been heard from since.

It would be great if this could be resolved as it's clear that there are a large number of people affected by this 'bug'.

regards


mintslice
Re: 4.4.2 update error Greg Marshall 101 1/18/14 10:59 PM
Also, my Nexus 4 is just over a year old now.  The retailer will not replace it...  Google's lack of support on this issue is very disappointing.
Re: 4.4.2 update error Gareth Smith 1/22/14 12:23 AM
Another botched updated attempt this morning. Tried everything that Paul has suggested above, because it is now (just) over a year old my retailer won't touch an RMA and says it has to be dealt with by Google (despite showing them the comment above from Paul).

The tablet is becoming increasingly unreliable with applications crashing, the tablet freezing up completely and GPS accuracy has taken a huge nosedive since 4.2 ... I'm sure Google's answer will be "all these items are corrected in 4.2.2". That would be the 4.2.2 that won't install OTA when all the previous updates right from the original JDQ39 have been OTA.

I find Google's lack of response extremely frustrating given that I (like many other Nexus device owners) bought a Nexus device to ensure that I could have the latest Android OS on my device and get around the bloat that OEM vendors and networks put on "their" devices
Re: 4.4.2 update error Joseph Richman 1/22/14 11:43 AM
If you're finding no other method is working, it might  be best to backup your current information and re-image completely for the latest version of your device. Google's lack of support on the issue for users who haven't done things such as rooting or re-imaging is disappointing. However if all else fails it might be the best way to get to 4.4.
Re: 4.4.2 update error Gareth Smith 1/22/14 12:04 PM
Joseph, I'm afraid you seem to have missed the part where my device has never been rooted or otherwise modified and has only had OTA updates since I purchased it. While I know how to do a push update I don't feel I should have to reimage a completely stock device. I have already had to "rebuild" the device a number of times through Paul's "advice" to do a factory reset and backups not always restoring correctly.

So I say again I find it extremely disappointing that Google are not providing support for a STOCK unmodified device let alone something that has been rooted.

Re: 4.4.2 update error Heikki Levanto 1/27/14 2:55 AM
I have the same problem, my LG Nexus 4 keeps telling me that there is a system upgrade to 4.4.2, it gets stuck in the error picture, and all is quiet until something like a week later, it tells me the same thing. I have tried to run the upgrade in safe mode, I have tried to clear the cache, nothing helps. I have never rooted the phone. I have very few apps installed, and nothing else. My radio version seems to be .97, so that is probably not the problem. My phone did a system upgrade to 4.4 (presumably from 4.3, not sure), but I have never seen 4.4.1 - maybe that is the problem, as some folks point out here.

Unlike some people here, I have no problem with running 4.4. I think I wait until 4.4.3 comes out, and hope its upgrade will not fail the same way. Unless someone can tell me a good (and safe) trick how to get over this. If need be, I may try a factory reset, but judging from what I read here, I am not too keen to go through all that hazzle right now.
Re: 4.4.2 update error Guilherme Bianchi 1/30/14 11:57 PM
I am having the same problem, I tried to use the recovery mode after the 10th time trying to install the new android version.

Now my cellphone shows a white box saying ''DOWNLOAD MODE, DO NOT UNPLUG THE DEVICE".

Damn, I really liked the cellphone, but I guess its the last time I buy a nexus.

Re: 4.4.2 update error Jay Freeman 2/15/14 2:09 PM
Hello everyone!

I posted on this thread before with the same issue and I'm happy to say I've resolved it...at least on my Nexus 4!

I followed rogerillu's post here http://forum.xda-developers.com/showthread.php?p=48427817 however on the last step, instead of 'fastboot update yourimagefile.zip' I did the usual 'fastboot flash-all.bat' to sideload the 4.4.2 update by fastboot.

Just to confirm, I did this using Windows, not a Mac like rogerillu did. It's quite simple, really. If you've ever sideloaded an update by adb or fastboot then you should be able to do this, fine.

Still no idea why this issue has happened but I've managed to fix it, which is the main thing!

If anyone needs any help, feel free to reply and I'll do what I can!

Jay
Re: 4.4.2 update error ozi keri 2/15/14 2:13 PM
Will give it a try tomorrow and let you know my results.
Re: 4.4.2 update error K-gyer 2/26/14 12:51 PM
I've been trying to update from 4.3 to 4.4 for months.  It errors every time.  
Re: 4.4.2 update error Bruno Repetto 3/1/14 8:23 PM
Its very annoying. Even after a factory reset can't get my nexus 7 (2012) from 4.4 to 4.4.2
I think it's Google responsibility get this fixed asap.
Thanks.
Re: 4.4.2 update error Pablo Vicuña 3/18/14 7:07 PM
i follow this steps and now my nexus 5 is freeze in the boot logo... 
More topics »