Slow/No buffering

Showing 1-4 of 4 messages
Slow/No buffering jackisnotback 5/4/12 2:15 PM
So, as you can see from the title, youtube is taking FOREVER to buffer videos, and sometimes they don't buffer at all. I have the latest flash player, java, cleared the cache/ cookies, checked my modem and everything youtube has advised on its help site, and yet its performance is still shocking. It takes 35 MINUTES to load a 4 minute video at 360p. Can anyone please help with this problem?
Re: Slow/No buffering Crusheddiamond 5/4/12 7:18 PM
I'm having the same issues, I have comcast located in denver, colorado. My speed is 22m down and 9m up. Whenever I load anything on youtube it doesnt buffer and i've done all the things you have im thinking it may be a possible issue with our ISP's.
Re: Slow/No buffering Teresa_ 5/5/12 5:15 AM
Right click over your video and you will see "report playback issue".
Re: Slow/No buffering AG_A 5/5/12 5:45 AM
I have this problem all the time. It's quite strange when I can use a proxy on the other side of the world to stream HD video nice and steadily, but if I use my local ISP route, it's 'buffermania' you might say. It happens about 50% of the time. Even 240p struggles at times. It doesn't matter what time of the day it is. I've had this problem for about 5 months now.

10 meg down.. 1 meg up. I can stream 1080p Netflix without a hitch but a regular vanilla Youtube video struggles on all of my machines unless I go through a proxy. Go figure?

Teresa_ offers good advice though. Report the issue at your convenience.