Categories: Problems and Errors : Linux :

Google Earth 5.1 and wrong coordinates

Showing 1-13 of 13 messages
Google Earth 5.1 and wrong coordinates Zimmer 9/10/09 2:47 PM
I have noticed that GE 5.1 now uses Qt4-4.5.2.

Unfortunately, it seems that the "wrong coordinates bug" is still here.
City names are in the wrong position.

Re: Google Earth 5.1 and wrong coordinates Zimmer 9/11/09 1:31 PM
Problem solved!

The bug is in the Qt4-4.5.2.

If LOCALE is setted to a language that uses 'comma' as decimal separator (for example, it_IT), then Qt4-4.5.2 truncates the decimal part of a real number; for example, 35,2 becomes 35

If you have this problem, edit the script /opt/google-earth/googleearth
Search for the line:

export LD_LIBRARY_PATH

and add hereupon:

export LC_ALL=us_US.UTF-8

Re: Google Earth 5.1 and wrong coordinates pete.dawgg 9/23/09 9:21 AM
for a german system using export LC_ALL=us_US.UTF-8 creates additional problems: names with umlauts in them cannot be entered into or found by ge. if there is a place called TÖWN it will not be found and this name cannot be entered into the searchbox. i think this is because LC_ALL replaces everything. instead of LC_ALL i  now use LC_NUMERIC and TÖWN is found at the right postion with the right name.
Re: Google Earth 5.1 and wrong coordinates Zimmer 9/23/09 10:35 AM
Pete, you are right. Your solution is better.

I do not have that problem because I have system LOCALE=it_IT.UTF-8
(see /etc/profile.d/lang.csh and /etc/profile.d/lang.sh)

Re: Google Earth 5.1 and wrong coordinates pete.dawgg 9/24/09 9:15 AM
thank you, Zimmer, but i have to revise my solution.
when i use LC_ALL and start googleearth with no style params or with "-style plastique" then the search-boxes are black and/or filled with unreadeable scrambeled garbage. when i start ge with "-style gtk+" everything is readeable and ümläüts are accepted, but the poosition bug is still there.
so now everything works with export LC_ALL=en_US.UTF-8 and "googleearth -style gtk+"

is there maybe a small typo in your original post? i use "en_US.UTF-8" now because "us_US.UTF-8" produced a warning.
also i copied everything from /usr/lib/qt4/ to /opt/googleearth/ (overwriting what was there), but i don't think this matters (much).

i suspect this is a bug in ge's usage of qt somewhere, because in this case i use a kde-3.5 system which i keep as qt4-free as possible. on another system (with fluxbox as wm) in ONLY works with LC_ALL, or all my gps-tracks are transferred to the same place (where i've never been). maybe LC_NUMERIC only seemed right before i used my own gps-tracks.
thx again for your helpful input which proved right!
Re: Google Earth 5.1 and wrong coordinates Zimmer 9/24/09 3:19 PM
Qt4 libraries have a big influence on support of national characters.

First of all, GE 5.0 works only with Qt4-4.3.3; GE 5.1 works only with Qt4-4.5.2.

Qt4 libraries that come with GE are unable to reproduce chinese characters,
japanese characters, and many other national characters.

You need to do these steps:

1) remove all the libQtxyz from the google-earth directory;
2) remove all the files from google-earth/plugins/imageformats;
3) edit the file google-earth/qt.conf and fill it with this rows:

[Paths]
Prefix=/usr/lib/qt
Documentation=doc
Libraries=lib
Binaries=bin
Plugins=plugins
Translations=translations

Obviously, you need to change the "Prefix" option accordingly to your
Qt4 installation.

P.S. LC_NUMERIC works perfectly for me.

Re: Google Earth 5.1 and wrong coordinates haploid 11/10/09 3:44 PM
Hi,

I have the same problem and ths suggested solutions did not work for me. Neither exporting LC_NUMERIC (or LC_ALL) as above, nor Zimmer's instructions.

As for removing libQ*, it turned out that googleearth needs the file libQtWebkit.so.4, and when i left this in the google directory it started up normally. I guess the system libqt4-webkit is written differently. Anyway, this lib is related to web content so i hope it would not matter. (Can i point googleearth to this one specifically via the file qt.conf ?).

Except for the webkit library, i followed the instructions literally.

Of course i used en_US.UTF-8 and i also adjusted the path to /usr/lib/qt4.
But the whole changes did not show any effect.
When i tried qt3 instead it was quite as broken as before.

This is Google Earth 5.1.3509.4636 (beta) from Sep 17, 2009, on a a recent Debian Sid Linux, qt 4.5.3-4.
Re: Google Earth 5.1 and wrong coordinates haploid 11/10/09 8:22 PM
I found that the linux Googleearth scrambled all my bookmarked placemarks at some point in the past (cutting all figures after the comma). When i looked at my placemarks it seemed as if it was still broken, but only the placemarks were, not the application. I had to restore myplaces.kml from an old backup. Now it seems to work again.

I counterchecked that by exporting my native locale again. Immediately myplaces.kml was scrambled again.

Pls be advised to backup this file to a safe location (or, create an additional copy in the same folder but with custom name.) because the file myplaces.bakup of the GE user folder also was scrambled, it did not work to restore only this. I had to restore from the additional backup again.

Many thanks to Zimmer for tracking this problem !
Re: Google Earth 5.1 and wrong coordinates Zimmer 11/11/09 1:28 PM
Haploid, yes, I have forgotten to say that the workaround requires to flush the cache and to delete all the bookmarked placemarks.

Re: Google Earth 5.1 and wrong coordinates jarl_cph 11/20/09 2:53 AM
To let you know, I have just created a bug report (including a minimalistic patch) in the Medibuntu project:
https://bugs.launchpad.net/medibuntu/+bug/485730

Jarl
Re: Google Earth 5.1 and wrong coordinates rm0768 4/16/10 10:21 AM
Congratulation ... this more or less deleted all my own tracks and points ... great !
Re: Google Earth 5.1 and wrong coordinates picard12 10/21/10 11:49 PM
Google Earth 5.2.1.1588 on mandriva 2010.1 have the same problem.
with the solution above is resolved, but you can not include it in permanently?
Re: Google Earth 5.1 and wrong coordinates Map123 10/17/11 2:05 PM
Google Earth 6.0 keep saying 'Google Earth has a problem and need to close' Can someone fix this?