Chrome not rendering Helvetica correctly

Showing 1-108 of 108 messages
Chrome not rendering Helvetica correctly Venceremos 4/7/12 9:08 AM
Chrome is not rendering Helvetica correctly at the moment (I've attached 2 JPEGs showing mmafighting.com and Twitter on Chrome, and another JPEG of mmafighting.com on IE). Encoding is set to auto detect, although it renders this way on all choices of encoding.

Not an issue in any other browser, or Chrome on another machine. I've tried uninstalling Helvetica but see the same issue.

Any ideas as to what could be causing this?

Many thanks

Re: Chrome not rendering Helvetica correctly wár17 § 4/7/12 10:28 AM
Clear browser cache and cookies. For time frame, select Since the beginning of time.
Re: Chrome not rendering Helvetica correctly Venceremos 4/7/12 1:27 PM
Unfortunately this has no effect. I'm assuming it doesn't cache fonts but I tried regardless and still see the same issue. I'm a little confused as to why Chrome would fail to render it but Opera/Firefox/IE can.

I can download an extension to force an override of the font but I'd rather correct the issue, rather than manually override on pages where I get this problem.

Re: Chrome not rendering Helvetica correctly wár17 § 4/7/12 2:27 PM
It could be an encoding issue.  Go here chrome://settings/fonts  Select UTF-8
Re: Chrome not rendering Helvetica correctly Venceremos 4/7/12 3:21 PM
Thanks for the help, but unfortunately I get this on all choices of encoding. I think it's an underlying font issue - as you can see from the screenshots, bold Helvetica renders correctly, but normal weight does not! It's just thrown me a little why it would be different in Chrome to any other browser.
Re: Chrome not rendering Helvetica correctly TheHeat 4/17/12 2:25 AM
I'm having the same issue, just Helvetica font-weight:normal!
Craig Long 4/17/12 2:55 AM <This message has been deleted.>
Re: Chrome not rendering Helvetica correctly theMlyon 4/19/12 11:47 AM
I am having the same issue w/ google and helvetica. Anyone have a solution?
Re: Chrome not rendering Helvetica correctly wár17 § 4/19/12 12:07 PM
theMlyon, did you try the suggestions posted?
Re: Chrome not rendering Helvetica correctly Venceremos 4/19/12 12:09 PM
I have since resolved this issue, but unfortunately it was more by luck than judgement. I essentially removed all Helvetica fonts (Standard, World and Neue) and reinstalled just Helvetica Neue.

I have no idea why this worked, or if it will work for anyone else, but for some reason it did the trick for me.

It's also worth noting that removing Helvetica entirely didn't solve the issue, and even after reinstalling just Neue it didn't seem to take effect immediately

Re: Chrome not rendering Helvetica correctly benguth 5/24/12 3:26 PM
I am having this exact same problem. Helvetica regular seems to be the only font that isn't encoding properly, and it's only happening on chrome.  I can't remove helvetica, as it's a system font. Are there any chrome solutions to this issue?
Re: Chrome not rendering Helvetica correctly kdelin 6/18/12 11:24 AM
Same here. I figured it was some bug in the latest chrome build, but just got tired of waiting for a fix and removed Helvetica from my system.  
Re: Chrome not rendering Helvetica correctly Riccardo B 6/20/12 12:34 AM
Same here: wrong rendering on Chrome, correct on Firefox 13 and IE9.
Re: Chrome not rendering Helvetica correctly wár17 § 6/20/12 8:55 AM
What version of Chrome are you using?
Re: Chrome not rendering Helvetica correctly kdelin 6/20/12 9:11 AM
Version 19.0.1084.56

I actually put my Helvetica back and just used the custom.css to remap helvetica, helvetica neue and sans serif to arial. That doesn't fix the bug, but at least I don't have to see a broken font.

Re: Chrome not rendering Helvetica correctly Riccardo B 6/30/12 2:29 AM
I forgot to say that my Chrome is 20.0.1132.47 m
and I'm on Windows 7 HP 64bit (always up-to-date by Windows Update) logged as administrator.
Re: Chrome not rendering Helvetica correctly MossBeep 7/12/12 8:38 PM
Has anyone gotten this fixed?

I have cleared browser cache and cookies Since the beginning of time and it still has not worked.

I am using Chrome 20.0.1132.57
Win7 64 bit, and everything is up to date.

Re: Chrome not rendering Helvetica correctly M80P 7/19/12 7:19 AM
I've found this solution. This apparently works only till the browser updates itself. :)

http://www.mroughton.net/blog/helvetica-neue-chrome-bug-fix/

Re: Chrome not rendering Helvetica correctly Juppee 9/25/12 2:16 AM
Seems Mr. Roughton took his blog down. Can anyone share the solution posted on this blog?
Re: Chrome not rendering Helvetica correctly ricardoreis 10/30/12 3:20 AM
here is the solution: http://thomaslittle.tumblr.com/post/13973246295/chrome-helvetica-bug-fix-for-windows-7
Re: Chrome not rendering Helvetica correctly Syd Salmon 11/6/12 9:52 AM
On OS X, the CSS file is located at:
/Users/user_name/Library/Application Support/Google/Chrome/Default/User StyleSheets.

Inserting the following line in the file Custom.css fixed it for me:
@font-face { font-family: 'helvetica'; src: local('Arial'); }

Re: Chrome not rendering Helvetica correctly Groupe DSI Analytics 11/20/12 1:11 PM
This thing works but not on all Helvetica, it seems when it's Helvetica-bold the problem's still here. You can see an example of what i'm saying there:
http://www.google.com/recaptcha/learnmore

Without the CSS fix the main text and the menu/title elements render incorrectly. When i apply the fix the main text switch to arial but the menu and page title and  the following text still display as helvetica:

The words above come from scanned books.
By typing them, you help to digitize old texts.

Right now i'm using Font Changer to change the default font of the web pages i gotta use often but every now and then i stumble across a webpage using helvetica and i see there's still a problem...

Re: Chrome not rendering Helvetica correctly Juppee 11/22/12 8:49 PM
html, body {
        text-rendering: optimizeSpeed !important;
}

I used this instead of font-face and worked for me on Helvetica

Re: Chrome not rendering Helvetica correctly Groupe DSI Analytics 11/23/12 11:25 AM
First time i see this solution brought up but it doesn't do it for me. Although i see a slight change in the space between letters the font is still broken.

I joined a screenshot of the web app we use to keep track of our work hours, it's called Harvest and it's one of the reason i really need this font problem fixed. The font used in the screenshot is Helvetica Neue.

I already tried the following fixes:

@font-face { font-family: 'helvetica'; src: local('Arial'); }
@font-face { font-family: 'helvetica neue'; src: local('Arial'); }

html, body {
        text-rendering: optimizeSpeed !important;
}

Theses fix works for Helvetica and Helvetica Neue but it doesn't affect Helvetica Neue - Bold

Re: Chrome not rendering Helvetica correctly ficho 12/18/12 1:07 PM
This worked great for me.
God i'm so glad its fixed been having this issue for years
Re: Chrome not rendering Helvetica correctly CMe2 1/23/13 8:01 AM
Here's what worked for me to fix Helvetica Neue and Helvetica Neue Bold in Firefox and Chrome. The first line fixes the plain font and the second line fixes the bold.

To Fix Helvetica Neue in Chrome:
Browse to C:\Users\YOURUSERNAME\AppData\Local\Google\Chrome\User Data\Default\User StyleSheets\Custom.css

Edit the custom.css file to add these two lines:
@font-face { font-family: 'helvetica neue'; src: local('Arial'); }
@font-face { font-family: 'helvetica neue'; font-weight:bold; src: local('Arial'); }

You should see the changes immediately as soon as you save the custom.css file.

To fix Helvetica Neue in Firefox:
Browse to  C:\Users\YOURUSERNAME\AppData\Roaming\Mozilla\Firefox\Profiles\xxxxxxxx.default\chrome

In this folder, edit userContent.css (or create it in notepad if it doesn't exist) and add these two lines:
@font-face { font-family: 'helvetica neue'; src: local('Arial'); }
@font-face { font-family: 'helvetica neue'; font-weight:bold; src: local('Arial'); }

You will need to close firefox and reopen it to see the change.

Good luck, hope it works for you too :)

Re: Chrome not rendering Helvetica correctly Tabitha Grow 1/27/13 12:40 PM
THANK YOU THANK YOU THANK YOU I've been trying to fix this for months!
Re: Chrome not rendering Helvetica correctly Kathy Benfield 1/31/13 6:43 AM
Thanks. This fixed it for me without the need for any of the additional lines mentioned after this post. Finally!, like most people I too have been looking for a solution for months.
Re: Chrome not rendering Helvetica correctly alexterryuk 2/5/13 3:08 AM
For an easy way to add this code use the Chrome extension Stylish

https://chrome.google.com/webstore/detail/stylish/fjnbnpbmkenffdnngjfgmeleoegfcffe?hl=en

Thanks for your help!

Re: Chrome not rendering Helvetica correctly Don Dudenhoeffer 2/14/13 11:12 AM
Stylish fix was great, wound up having to insert the following code to fix all my issues though:

@font-face { font-family: 'helvetica neue'; src: local('Arial'); }
@font-face { font-family: 'helvetica neue'; font-weight:bold; src: local('Arial'); }
@font-face { font-family: 'helvetica'; src: local('Arial'); }
@font-face { font-family: 'helvetica'; font-weight:bold; src: local('Arial'); }

Re: Chrome not rendering Helvetica correctly cardy_web 2/18/13 1:32 AM
Thanks a lot! This solution worked for me.
Re: Chrome not rendering Helvetica correctly hromero 3/4/13 5:07 AM
This Work Very Well

Browse to C:\Users\YOURUSERNAME\AppData\Local\Google\Chrome\User Data\Default\User StyleSheets\Custom.css

Add This

@font-face { font-family: 'helvetica neue'; src: local('Arial'); }
@font-face { font-family: 'helvetica neue'; font-weight:bold; src: local('Arial'); }
@font-face { font-family: 'helvetica'; src: local('Arial'); }
@font-face { font-family: 'helvetica'; font-weight:bold; src: local('Arial'); }

Re: Chrome not rendering Helvetica correctly Chris..Hewitt 3/7/13 2:46 AM
Hi Syd,

Just wondered if you new how to do this for Mountain Lion... In my user folder I dont have a Library folder :( which i dont know if that is normal or not... I can see in my Guest user it has a library folder. I want a library folder!

I do this: HD/User_name/no library :(

the only Library I can find is here:

HD/library/application support/ and there is no google folder there....

best,
C

Re: Chrome not rendering Helvetica correctly Nathan Garner 3/7/13 1:46 PM
Click you alt key and go to the menu 'Go' at the top and your library will be visible.
Re: Chrome not rendering Helvetica correctly Chris..Hewitt 3/8/13 1:01 AM
Thanks Nathan - worked a treat.
Re: Chrome not rendering Helvetica correctly Adam157 3/17/13 11:41 PM
Job Done. Thank you
Re: Chrome not rendering Helvetica correctly Nicole Kohler 3/18/13 8:45 AM
THANK YOU SO VERY MUCH.
Re: Chrome not rendering Helvetica correctly Peter River 3/23/13 1:13 PM
Replacing Helvetica with Arial is a less than ideal workaround. It's much better to tackle the issue directly by adding the following code to Chrome's Custom.css file:

* {
text-rendering: auto !important;
}

That way the issue can be solved without replacing Helvetica with an inferior typeface.

This article points the file's location in different operating systems: http://goo.gl/iiAJZ

Re: Chrome not rendering Helvetica correctly Peter River 3/23/13 1:15 PM
Re: Chrome not rendering Helvetica correctly Adam157 3/24/13 4:11 PM
Hi Peter,

Gave your suggestion a shot and it had no effect. Back to the Helvetica substitution which I agree is not an ideal solution.

Thanks

Re: Chrome not rendering Helvetica correctly mattand08 3/27/13 8:58 AM
Hey, CMe2:

Thanks for the tip! This worked for me in chrome. The only oddity was that the custom.css page was blank. Literally the only two lines of code in it are the ones you suggested.

For Mac users, you need to navigate to User/Library/Application Support/Google/Chrome/Default/User StyleSheets/Custom.css

Note: Apple has hidden the User Library in 10.7 Lion on up. You need to hold the option key while selecting the Go menu in the Finder.

Re: Chrome not rendering Helvetica correctly Le Robespierre 4/4/13 11:36 AM
This does not fix italic font-style, or font-weight or whatever. See the attached image.
Re: Chrome not rendering Helvetica correctly Joshuah s 4/4/13 10:56 PM
this worked for me thank you!
Re: Chrome not rendering Helvetica correctly Le Robespierre 4/4/13 11:13 PM
Update: I actually ended up deleting Helvetica completely from Windows safe mode and replacing it with Roboto. A dirty solution, but it worked for me.
Re: Chrome not rendering Helvetica correctly Jaiman Jsmoke Yun 5/28/13 8:32 AM
For some reason my custom.css is blank... i tried opening it in dreamweaver cs6 and text edit and nothing...  
Re: Chrome not rendering Helvetica correctly Jaiman Jsmoke Yun 5/28/13 8:46 AM
Actually, I put in code:

@font-face { font-family: 'helvetica'; src: local('Arial'); }

and nothing happened...

Re: Chrome not rendering Helvetica correctly Florian Champi 6/19/13 9:19 AM
Thank you very much !

Merci beaucoup !
Problème enfin réglé sous Chrome, Facebook et son Helvetica peuvent enfin s'afficher !

Le mercredi 23 janvier 2013 17:01:04 UTC+1, CMe2 a écrit :
Re: Chrome not rendering Helvetica correctly RyanReformed 6/26/13 7:14 AM
Thank you so much! This worked for me. (Windows 8 Pro 64-bit).
Re: Chrome not rendering Helvetica correctly Sabina Siddiqi 7/1/13 7:09 AM
How do you remap helvetica to arial for the browser rather than an individual page?
Re: Chrome not rendering Helvetica correctly wanikkic 7/19/13 5:15 AM
GAWD thanks soooo much! Nothing, literally...nothing else I tried worked, only your solution!! THANK YOU :-D
Re: Chrome not rendering Helvetica correctly georgewfoster 8/22/13 4:09 AM
Having read this and using a Mac, I found it the easiest to open FontExplorer and close all the Helvetica fonts then reopen Helvetica Neue alone. Worked a treat - this has annoyed me for bloody ages! Ta all!
Re: Chrome not rendering Helvetica correctly AndrewG__ 8/25/13 8:06 AM
This worked for me as well. Thanks! (see below)

http://productforums.google.com/d/msg/chrome/J4dqHZD3dcs/dwxqyb_xG24J

On Wednesday, January 23, 2013 8:01:04 AM UTC-8, CMe2 wrote:
> Here's what worked for me to fix Helvetica Neue and Helvetica Neue Bold in Firefox and Chrome. The first line fixes the plain font and the second line fixes the bold.
>
> To Fix Helvetica Neue in Chrome:
> Browse to C:\Users\YOURUSERNAME\AppData\Local\Google\Chrome\User Data\Default\User StyleSheets\Custom.css
>
> Edit the custom.css file to add these two lines:
> @font-face { font-family: 'helvetica neue'; src: local('Arial'); }
> @font-face { font-family: 'helvetica neue'; font-weight:bold; src: local('Arial'); }
>
> You should see the changes immediately as soon as you save the custom.css file.
>
> To fix Helvetica Neue in Firefox:
> Browse to  C:\Users\YOURUSERNAME\AppData\Roaming\Mozilla\Firefox\Profiles\xxxxxxxx.default\chrome
>
> In this folder, edit userContent.css (or create it in notepad if it doesn't exist) and add these two lines:
> @font-face { font-family: 'helvetica neue'; src: local('Arial'); }
> @font-face { font-family: 'helvetica neue'; font-weight:bold; src: local('Arial'); }
>
> You will need to close firefox and reopen it to see the change.
>
> Good luck, hope it works for you too :)

Re: Chrome not rendering Helvetica correctly georgewfoster 8/27/13 4:20 AM
Dammit - still having problems on a Mac - anyone got a solution? Thanks
Re: Chrome not rendering Helvetica correctly Kyle Cullinan 9/9/13 1:55 PM
it worked!!! thank you! thank you! thank you! finally!
Re: Chrome not rendering Helvetica correctly stevebower 9/23/13 4:45 PM
Thanks to Peter & Don - both worked.
I guess I prefer Peter's approach in that it 'forces' the intended page style, rather than a less satisfactory substitution.
Hope I can find this thread again when I reinstall!
Cheers
Re: Chrome not rendering Helvetica correctly Oxydron 9/24/13 9:12 AM
There is a way that fix the problem for every browser.
Install the MS Office 2007/2010/2013, it fix the problem,
because it resets the fonts to the original, so to speak.
Re: Chrome not rendering Helvetica correctly Kevin Sucianto 9/24/13 10:36 AM
I've tried the following, unfortunately nothing changes in my Chrome.
Version 29.0.1547.76 m

Helvetica Neue will text normally for numbers, letters, and common special characters only such as commas and fullstop. Other special characters would result in error, showing the diacrytic I and O, which always " í" and "◌̈".
Re: Chrome not rendering Helvetica correctly Oxydron 9/24/13 2:40 PM
I forgot to say, there are 3 steps:
1 - Delete ALL Helvetica fonts, from yout font folder.
2 - Go to your Registry Editor and delete every Helvetica entry.
(Start -> type 'regedit', then press ctrl+F e type 'helvetica')
3 - Install/repair your MS Office 2007/2010/2013.
Re: Chrome not rendering Helvetica correctly daniel ling 10/14/13 11:52 AM
CMe2's answer ROCKED!!! I've been living with this problem for ages.

Slight edit for me- the problem was Helvetica, not Helvetica Nue. So I added the following 2 lines in the respective Custom.css files:

@font-face { font-family: 'helvetica'; src: local('Arial'); }
@font-face { font-family: 'helvetica'; font-weight:bold; src: local('Arial'); }

Other than that, followed the instructions in his post. Worked like a charm!

Re: Chrome not rendering Helvetica correctly Herman Figueiredo 10/21/13 7:19 PM
Its work for me:
@font-face { font-family: 'helvetica neue'; src: local('Arial'); }
@font-face { font-family: 'helvetica neue'; font-weight:bold; src: local('Arial'); }
Funcionou para mim.
Re: Chrome not rendering Helvetica correctly Arion Kabashi 11/21/13 4:21 AM
BIG TIME. Thanx
Re: Chrome not rendering Helvetica correctly Delia Clare 11/29/13 6:01 PM
Thank you thank you thank you!
Re: Chrome not rendering Helvetica correctly LukeD1uk 12/15/13 11:37 AM
Worked Perfectly :D
Re: Chrome not rendering Helvetica correctly S.Fisher 12/27/13 4:43 AM
I've had this problem for months, thanks so much! Works perfectly.
Re: Chrome not rendering Helvetica correctly DeliciousTurtle 1/6/14 10:30 PM
thanks, this worked.
Re: Chrome not rendering Helvetica correctly Will Knight 1/23/14 2:23 AM
Hi there Vanceremos,

The answer from CMe2 led me to realise that for me it wasn't actually Helvetica not displaying correctly but Helvetica Neue. Therefore I found a download for the Helvetica Neue font like this - http://crossgraphicideas.wordpress.com/2012/08/14/helvetica-neue-font-free-download-complete-family/

Once I had downloaded and installed it everything is now displaying correctly again.

Either way, thanks for the help from CMe2 for solving this issue.

Re: Chrome not rendering Helvetica correctly Виктор Климов 2/4/14 11:46 AM
Had same issue with HelveticaNeue font in Chrome on Windows 7 after installing other Helvetica Neue family fonts. I'am opened Control Panel > Fonts and type Helvetica in search box. Few Helvetica fonts appear in window. I'am just deleted HelveticaNeue fonts and restart browser. Now all work fine. Hope this help for anyone.
Re: Chrome not rendering Helvetica correctly Marilize Nel 2/7/14 1:43 AM
Great solution! I can't thank you enough!! I've been struggling with font rendering issues in Chrome for a couple of weeks and your instructions worked perfectly. Thank you!
Re: Chrome not rendering Helvetica correctly Florencia Coppola 2/20/14 6:20 AM
Worked like a charm! Thank you!
Re: Chrome not rendering Helvetica correctly Milana Adamov 2/21/14 12:14 AM
Thanks a lot for this, It worked - till today, from today though - it shows Helvetica again and in a most unpleasant of ways - I have no clue what may have caused the custom user css to fail...Attached is the image...

Re: Chrome not rendering Helvetica correctly FatalWaffles 2/21/14 3:10 PM
I had originally "fixed" this issue before with the edits to the custom.css as well and today the issue has reappeared. My custom.css is still there and contains the lines above in CMe2's post. I hope someone can offer some insight and help.
Re: Chrome not rendering Helvetica correctly Lộc Cao 2/22/14 12:27 AM
same problem here... I think it's because Chrome has updated to version 33.
I've fixed this error with CMe2's solution just about a month ago. 
but now, it turns back to error-font again although I don't change anything in custom.css.
Re: Chrome not rendering Helvetica correctly Joshuah s 2/22/14 7:42 AM
Same it looks like the custom CSS no longer works. No my facebook page has some condensed bold font on it ant it's just awful to read. 
Re: Chrome not rendering Helvetica correctly coder... 2/22/14 11:19 AM
same problem here, and it's a new problem. Fixes don't work, and I see the helvetica is added in many stylesheets in the cache folder. 
Also my web inspector shows that the default core.css is pulled from https://d2k1ftgv7pobq7.cloudfront.net/css/e0da48047979356edabe1ade647a07c1/core.css , so...can't change that :|
Re: Chrome not rendering Helvetica correctly Cadistra 2/22/14 11:59 AM
Yup, I just stumbled across the same problem (along with them taking away the option to turn off extended API for those "most recently visited sites" thing...good thing I found a workaround.). Good frigging grief, Google. Get your act together.
Re: Chrome not rendering Helvetica correctly Phi66 2/24/14 7:25 PM
II found this temporary solution. Install the extension "HelvetiGone" for chrome and click on the top right when you need it.


Re: Chrome not rendering Helvetica correctly Cadistra 2/24/14 7:55 PM
But it replaces everything with comic sans. :'(
Re: Chrome not rendering Helvetica correctly Phi66 2/24/14 8:52 PM
Re: Chrome not rendering Helvetica correctly Phi66 2/24/14 8:56 PM
it remains in the background of chrome and automatically changes to Arial
Re: Chrome not rendering Helvetica correctly Phi66 2/24/14 9:09 PM
or you can change the fonts by clicking "option" in >> chrome://extensions/
Re: Chrome not rendering Helvetica correctly Carlo Nunyes 2/24/14 9:23 PM
I am facing the problem again when I updated my chrome. Is there a permanent solution to this? Its bold fonts are on yahoo, tumblr, facebook and other sites on google.
Re: Chrome not rendering Helvetica correctly Ctyldsley 2/25/14 5:59 AM
Also having this problem on the latest version of chrome with Helvetica installed. This was previously resolved with the css fix, but as of the latest version this doesn't work anymore.
Re: Chrome not rendering Helvetica correctly Chris..Hewitt 2/25/14 6:16 AM
I managed to fix this a while ago with the CSS hack however I too fell victim to the latest google update. I was able however to solve my problem! For Mac go into your font folders and delete all helvetica files... The font folder in your user and the main system font folder. Try and empty your bin - you may get an error that some helvetica files are being used.... so restart your Mac and once it lets you take control again quickly empty your bin. This should let you delete all helvetica fonts. You can go into the folders again to double check... but they should have disappeared. Open Chrome and look at a page that once was a problem... You will see that it has be cured! BUT this is a problem because I now don't have Helvetica. I closed my Chrome. Over Skype I got a friend who has a Mac and who doesn't seem to be having this problem to send over his helvetica.dfont file. I opened it and selected it to be part of my fonts. I Opened my Chrome and looked at a previously troubled page - after code inspecting the text It appears that Helvetica is being rendered again and there is no problems! WoooooP.

Try this out with a friend and let me know if it worked for you too, Maybe a lot of unclean helvetica font files about.

Chris
Re: Chrome not rendering Helvetica correctly coolgus 2/28/14 1:23 AM
I really don't get how Google screwed this up. It's not a minor bug, it's a constant situation without a fix. We can't depend on hacks anymore. I love Chrome and I really can't use it anymore.
Re: Chrome not rendering Helvetica correctly AndrewG__ 3/1/14 5:27 PM
Me as well, this was resolved with the custom.css fix until the latest patch (Feb 2014) where it is now broken again.
Re: Chrome not rendering Helvetica correctly Florian Mücke 3/4/14 1:21 PM
Great one!
Re: Chrome not rendering Helvetica correctly apokalypseAATT 3/7/14 2:39 AM
so anyone found a NEW solution for this?

Chrome is just ignoring the custom.css :((
Re: Chrome not rendering Helvetica correctly coolgus 3/7/14 2:47 AM
I sure found one

Rollback to version 32 and registry hack in order to disable autoupdate :-)
Re: Chrome not rendering Helvetica correctly Milana Adamov 3/7/14 2:56 AM
I would rather stop using chrome altogether, they don't care about satisfying their users, no probs - find someone who does...and wave 
Re: Chrome not rendering Helvetica correctly Roger Ri 3/7/14 3:33 PM
A SOLUTION ! (deleting Helvetica Neue)

Go to windows start button -> search an execute regedit(.exe), then go through the following folders:
-> open folder HKEY_LOCAL_MACHINE -> SOFTWARE -> Microsoft -> Windows NT -> CurrentVersion -> Fonts

Then select and delete the ones that are Helvetica/Helvetica Neue and restart your computer. Then open chrome and it should look fine.  ;)
Re: Chrome not rendering Helvetica correctly Roger Ri 3/7/14 3:34 PM
A SOLUTION ! (deleting Helvetica Neue) :(


Go to windows start button -> search an execute regedit(.exe), then go through the following folders:
-> open folder HKEY_LOCAL_MACHINE -> SOFTWARE -> Microsoft -> Windows NT -> CurrentVersion -> Fonts

Then select and delete the ones that are Helvetica/Helvetica Neue and restart your computer. Then open chrome and it should look fine.  ;)
Re: Chrome not rendering Helvetica correctly Danijar Hafner 3/8/14 2:48 AM
This would cause Chrome to fallback to another font, right? I think that means it's the font, not Chrome, who is incompatible here. We may just need an UTF-8 capable Helvetica font, or have I misunderstood the problem? As webdesigner, removing the font is no solution for me.
Re: Chrome not rendering Helvetica correctly Roger Ri 3/8/14 3:29 AM
You are right, the problem is that the font is not rendering correctly in Chrome. I hope google fix this soon.
Re: Chrome not rendering Helvetica correctly apokalypseAATT 3/8/14 5:17 AM
hm that's no solution for me, I'm a web designer, removing the font is baaaaaad.

no tech-guy here who knows why the custom.css replacement for chrome doesn't work anymore? it was the perfect solutions, until the latest update :(

Re: Chrome not rendering Helvetica correctly Danijar Hafner 3/8/14 5:54 AM
What I meant is that the font file may not support UTF-8 correctly. So Google can't fix that. We just need a correct Helvetica font file. But as I'm said I am not sure about this. Is this correct?
Re: Chrome not rendering Helvetica correctly mullie346 3/8/14 1:09 PM
Since they decided to remove custom.css here is another fix. 

Go to C:/Users/YOUR_NAME/AppData stay here 
Now navigate to the search bar and type the following: style.css -> let windows index for a sec.

Hopefully you will get above 2 results -> navigate to "style.min.css" -> edit with notepad or notepad++ 
Now press CTRL+F to search. 
Type in Helvetica 

You should get 3 results surrounded by Qoutation marks ( "  " )  now delete everything inside the qoutation marks leaving them empty. from this "Helvetica Neue" to this ""  when done press CTRL+S now close notepad and restart Chrome. 
This worked for me i hope it works for you.
Re: Chrome not rendering Helvetica correctly apokalypseAATT 3/9/14 9:09 AM
didn't work for me :/

Re: Chrome not rendering Helvetica correctly Vlad V. 3/11/14 2:35 PM
Re: Chrome not rendering Helvetica correctly ChiBeerGuy 3/11/14 2:40 PM
This also kills @font-face
Re: Chrome not rendering Helvetica correctly ChiBeerGuy 3/11/14 2:41 PM
This also kills @font-face fonts
Re: Chrome not rendering Helvetica correctly apokalypseAATT 3/11/14 3:57 PM
that works! great, thanks!
Jesus Benitez 3/13/14 8:35 AM <This message has been deleted.>
Jesus Benitez 3/13/14 8:40 AM <This message has been deleted.>
Jesus Benitez 3/13/14 8:41 AM <This message has been deleted.>
Re: Chrome not rendering Helvetica correctly Jesus Benitez 3/13/14 8:51 AM
SOLUTION:
i made a little bit o research and as every one already discovered, Google Drop the custom.css support, so the introduced in Chrome 33+ "Themes".
So, modifying a couple of things will fix this bug.

2 - Extract in a safe place, if the folder its deleted, hasta la vista baby for the fix.
3 - in the ulr bar in chrome paste, chrome://extensions
4- In the top of the page, enable "Developer Mode"
5 - Click in "Load unpacked extension" and search for the extracted folder
6 - close and open chrome

A "warning" pop-up, will appear, just ignore it.
Hope it works for you :)
Re: Chrome not rendering Helvetica correctly Deo Felicidario 3/31/14 10:48 AM
This worked FINALLY. Thanks man!!!
Re: Chrome not rendering Helvetica correctly Jesus Benitez 3/31/14 11:00 AM
Just one thing that i found out, certain pages doesnt work if you dont click in the "cancel button" in the pop-up. Like iCloud
If the plugin stops working, just restart chrome, ill try to update it in my spare time.

Re: Chrome not rendering Helvetica correctly Gargi Pradhan 4/8/14 9:17 AM
THANKS! I had the same problem but this really helped!
More topics »