Google Product Forums

Re: Google maps UI painfully slow after latest revision


Zac Streelman Apr 1, 2009 11:01 AM
Posted in group: Google Maps
This exact problem just started happening for us this morning. I have posted my answers to the questions below.

1) When did you first notice this problem?
Today.

2) Can you quantify "incredibly slow", eg, "It used to take around 4 seconds to load Maps and now it takes around 20" or "Maps loads fast but search results take at least 15 seconds to come back" etc.
Maps usually load for us immediately. Now, the pages either don't load, or the tiles show "we don't have maps at this zoom level" (5). Oddly, I can still see routes, street views, satellite and terrain maps and traffic overlays - just not the actualy map itself. The rendered maps that do appear also don't have their same quality of "sharpness" as they usually do.

3) Which browsers, operating systems, and (if possible) security patchlevels do you have?
Problem duplicated on the following platforms
Windows - IE6, IE7, Firefox 3.0.0.8, Opera 9.5.2
Linux - Firefox 3.0.0.8, Konqueror, Opera 9.5.2

4) What other software is installed on your computer, eg, do you have any toolbars, chat clients, etc installed?
No toolbars, spyware, or other browser-interacting software installed on either OS.

5) If you know how to use the CPU monitoring facility of your operating system, is the CPU maxed out during page load, or does it seem to be waiting on the network?
CPU jumps about 20%, but nowhere near maxing out
6) Which area of the world are you connecting from? Metro-area granularity is ideal but I'll take country-level too :-)
Buena Park, CA (northern orange county, southern california)

Pings against maps.google.com over ~8-10 minutes show 1-2% packet loss
740 packets transmitted, 726 received, 1% packet loss, time 827926ms
rtt min/avg/max/mdev = 39.325/124.222/374.452/46.778 ms

Ping statistics for 74.125.19.99:
Packets: Sent = 1031, Received = 1007, Lost = 24 (2% loss),
Approximate round trip times in milli-seconds:
Minimum = 16ms, Maximum = 338ms, Average = 106ms

Traceroute shows the following:

traceroute to maps.google.com (74.125.127.103), 30 hops max, 40 byte packets
 1  64-60-21-65.static-ip.telepacific.net (64.60.21.65)  1.216 ms * *
 2  * * *
 3  * * *
 4  * * *
 5  * * *
 6  * 72.14.197.161 (72.14.197.161)  106.416 ms  131.139 ms
 7  216.239.46.182 (216.239.46.182)  165.136 ms  136.344 ms  133.335 ms
 8  * * *
 9  * * *
10  * * 64.233.174.101 (64.233.174.101)  152.450 ms
11  pz-in-f103.google.com (74.125.127.103)  168.847 ms  169.598 ms *


Please advise as soon as possible

Thank you
Zac Streelman