Google Product Forums

Re: Install Error 7: Install/update failed


baileydrai Apr 8, 2012 6:16 PM
Posted in group: Google Chrome Forum

Categories: Report an Issue :

When I check for updates it says my version of windows is not supported  even though I have windows xp professional sp3. I have tried re installing google chrome several times and it keeps giving me the message "Google Chrome requires Windows Xp or later. Some features may not work."