Google Product Forums

Re: Install Error 9: Current OS not supported


wintwok Mar 10, 2011 5:15 AM
Posted in group: Google Chrome Forum

Categories: Report an Issue :

Running XP -SP3 on an Intel dual core with all security updates through 03/09/11 installed yet Chrome does not recognize this configuration and refuses to install.  Google support is on par with MS, they have so many issues to deal with they don't have time to  read the entire ticket and their response is standard rather than directed to the problem.  The solution, download and install Firefox, Mozilla developers really have their act together.