Categories: Report an issue :


Showing 1-140 of 140 messages
Glitch? DarthNeko 8/25/14 11:54 PM
Every time I search something in Google images, these creepy images are appearing. It's apparently a crashed truck or something, but I didn't look it up. People could say that it had something to do with what I was searching, but if I click on it, a different image appears. I have some screenshots attached.
Re: Glitch? X Reaver 8/26/14 12:14 AM
Same here. I searched by the image and it's a picture of a Russian car crash involving some Christina person. Really creepy though. Hope it get's fixed soon because it's sort of irritating.
Re: Glitch? Cat M. 8/26/14 12:43 AM
I am relieved that others are experienceing the same thing.  I went to my classroom eBoard and had this car crash photo in the welcome banner instead of the cartoon Earth.  School starts in a week- what a welcome that would have been!  I removed the photo and went in search of a new photo to insert.  This car crash photo dominates the images no matter what image search I do hope this is resolved soon.  
Re: Glitch? Sharique.G 8/26/14 12:47 AM
Hi DarthNeko,
  • Did you try clearing your Cache and Cookies.?
  • Try using Chrome in Incognito Mode.
  • Also try Reinstalling your browser.
Post back if you still face issues.
Good luck!
Re: Glitch? bluequoll 8/26/14 12:50 AM
You might find this FAQ topic helpful:
"PUPs" - Potentially Unwanted Programs
Re: Glitch? Matthew Villani 8/26/14 12:50 AM
Happening to me, too. I thought it was a picture of a garbage truck at first. I think it's Google Images itself, not us.
Re: Glitch? Rosie Pringle 8/26/14 1:22 AM
I also am having this issue in Chrome, Firefox and Safari. Tried incognito mode, cleared cache, cookies, etc.  Seems to be a problem with Google Images, not with my browsers.
Re: Glitch? Amal Sk 8/26/14 1:36 AM
Hey all.
Did you all go through the FAQ which my friend bluequoll suggested above? Could you all confirm you face the same issue even after going through all the steps on that FAQ?

Good Luck!

Re: Glitch? Martina D 8/26/14 1:38 AM
Thank God I thought it was just me. No matter what I look up, that Russian car crash is the only result. I've tried clearing my history, cookies, everything and nothing. I hope this gets fixed soon because school is starting soon and I need this fixed.
Re: Glitch? Chris Markiewicz 8/26/14 1:43 AM
Yes, I have gone through the FAQ, I have uninstalled and reinstalled my browser, shut down my computer, messed with it's setup, restarted my computer, checked my security program and any other internet related thing. I can ASSURE you, that it is NOT my computer, or my browser, which then only leaves it to be Google Images itself.
Re: Glitch? Chris Markiewicz 8/26/14 1:49 AM
Oh, and to add another point, it's not just on one account or one computer. I've logged out of Chrome, Safari, IE, and Firefox and tried multiple accounts, and all of them have this issue.
(unknown) 8/26/14 1:51 AM <This message has been deleted.>
Re: Glitch? love alot 8/26/14 1:56 AM
Just use no problems there. Problem solved hurry and fix this glitch Google.
Re: Glitch? bluequoll 8/26/14 1:59 AM
I can't reproduce this, so I've no idea what's going on here. The image appears to come from a Ukrainian website:

This issue has been escalated for investigation. Please monitor this topic for updates or further comment.
Glitch? Janezstyle 8/26/14 2:02 AM
Happening on all browsers on my iPad, Android phone (Nexus 4) and two laptops. Definitely server and not user related.
Re: Glitch? Amal Sk 8/26/14 2:09 AM

Same here, can't reproduce the issue.

Re: Glitch? Adelyne Débora 8/26/14 2:18 AM
I'm from brazil and having the same issue. Is everywhere and every search I do appears only like five related images and the rest is all this image. I tried to clean up everything, see some fishing related issues but nothing happened. I hope they can give me some help soon or fix it.
(unknown) 8/26/14 2:51 AM <This message has been deleted.>
Glitch? Andrew Klinedinst 8/26/14 2:54 AM
This is a problem only on certain networks.  Trying to duplicate it.  If anyone who's getting this is familiar with how to retrieve their DNS server information I'd love to get my hands on it.  In the mean time if you really need to use google search try using
Re: Glitch? Andrew Wakely 8/26/14 2:58 AM
I just an hour ago asked about the very same thing. Creeped me out when it began happening.
I must say, Im relieved others had this problem. I was hoping I didnt have a bug or something equally as weird.
(unknown) 8/26/14 3:06 AM <This message has been deleted.>
Re: Glitch? Chris Markiewicz 8/26/14 3:28 AM
I've tried it on multiple different Networks, and still the same result.
Re: Glitch? Adelyne Débora 8/26/14 4:13 AM
The only working fine is bing at least for me.
Re: Glitch? Andy-Samuel Voltaire 8/26/14 4:18 AM
I'm having the same issue, it's a little weird.
Re: Glitch? Alexandre Queiroga 8/26/14 4:27 AM
Same here
(unknown) 8/26/14 4:28 AM <This message has been deleted.>
Re: Glitch? Adelyne Débora 8/26/14 4:33 AM
Mine, updated.  I wonder where people in charge of fixing this are right now. It's really bad that nothing changed and seems worse now. This is something very annoying and I wonder if it was something like someone with a crushed head or something. Google should have better care for this stuff. Seriously.
(unknown) 8/26/14 4:38 AM <This message has been deleted.>
(unknown) 8/26/14 4:46 AM <This message has been deleted.>
Re: Glitch? Alexandre Queiroga 8/26/14 4:50 AM
Should we have to remove and reinstall Chrome?
I'm having the same problem with tablet ( and desktop )
Re: Glitch? 8/26/14 4:59 AM
Hi Andrew, +1, I'm getting this through Google's public DNS (,

host has address


host has address


Re: Glitch? Stephanie Melendez 8/26/14 5:00 AM
I'm having the same problem, and with out being connected to my google account. I tried it from my cellphone, from mmy work desktop computer...and nothing.. Google has been hacked?!?!
(unknown) 8/26/14 5:01 AM <This message has been deleted.>
Re: Glitch? A Gif of the problem 8/26/14 5:03 AM
Same issue. Animated to show how the image changes when you click it. Definitely a cache problem.


Re: Glitch? Sheppy99 8/26/14 5:15 AM
From Canada and am having the same issue. Looks like google has been compromised. I am having this issue on every browser and device in my home including tablets and cell phones.

Apparently whoever has done this wants us to know about this car crash...... Very eerie situation all round. Hopefully google fixes it soon.

Re: Glitch? Sheppy99 8/26/14 5:18 AM
Just noticed that when I try to do the search through my cell phone companies data  network and not my wifi, I do not have the issue. Very strange indeed....

Does this mean network providers are being hacked and not google itself?

Re: Glitch? Fonte Boa 8/26/14 5:22 AM
This seems to be part of Russia (Ucraine) X USA new cold war. A shame to google.
Re: Glitch? Benoit Casey 8/26/14 5:22 AM
Same issue here, both on my work PC and my Android phone (which are on 2 completely different networks).
Re: Glitch? J Philga 8/26/14 5:24 AM
Same issue here. Both of my phones, also Youtube thumbnails show as walking dead clips.
(unknown) 8/26/14 5:24 AM <This message has been deleted.>
Re: Glitch? Rayner Caliari farias 8/26/14 5:34 AM
One more from Brazil here with the same problem.
Re: Glitch? F Fequet 8/26/14 5:37 AM
Same here in Canada...repeat image...
Glitch? yanick.c 8/26/14 5:44 AM
I'm experiencing the same problem in Canada, including when doing a news search. Screenshot from Chrome Beta (Android):
Re: Glitch? Jason Hanley 8/26/14 5:46 AM
I have the same problem and suspect a region or network-specific CDN problem.

LIME DSL (Caribbean): Shows the problem

The Cable Internet (Caribbean): Does not have the problem

Glitch? Russian Car Crash 8/26/14 5:48 AM
Same problem here. I dont know much about these things, but is there any chance itcould involve a virus?
Re: Glitch? dsifjhlkasdfkladsf 8/26/14 5:48 AM
Hello, just jumping on to say at my office the computers are having the same issue. no matter what you image search after the first few images they are all either the car crash, or some NBA player.
Re: Glitch? Prime_8 8/26/14 5:48 AM
Same here .
I have all devices doing this from my laptops & desktops , droid cell , and nexus 7 tablet .

i have more than one isp ( Bell and Rogers ) , and router setup. I have cleared all caches and even wiped one PC by drive image , installed chrome and doing it .
 and even via my cell data plan add have same results .

but if i use the  it seems to not happen .

Re: Glitch? Vammpires 8/26/14 5:49 AM
I'm having the same problem too and it's really freaking me out! ;__;
Re: Glitch? Janet Grissett 8/26/14 5:49 AM
same here. nothing seems to fix the problem.
Re: Glitch? Sheppy99 8/26/14 5:51 AM
Seems to be a regional issue. While checking other sites regarding this issue, most people from Europe are reporting no issues with the exception of a few from Germany I saw but there is many having the problem in Canada and the USA.
Re: Glitch? Janet Grissett 8/26/14 5:51 AM
BTW, I tried to send feedback using google form but when it got to the highlighting the problem on the page part,I would highlight the wrong images but then it would come up and show what it was going to send to google, and it was correct images for the search item. So how can that be??
Re: Glitch? Janet Grissett 8/26/14 5:56 AM
does the same in incognito window too
Re: Glitch? Alexandre Queiroga 8/26/14 5:58 AM
South America as well
Re: Glitch? Russian Car Crash 8/26/14 5:58 AM
Is it safe to use google images now?
Re: Glitch? Rival Son 8/26/14 5:58 AM
All good here in the UK...
Re: Glitch? Russian Car Crash 8/26/14 6:01 AM
Anybody contact the media yet?
Same issue here, it appears to only be the US and canada. reddit's r/google is ull of people having this same issue. Fix it google! i hate bing.
you cant mark your as the best answer lol. Its not to reproduce this issue all you need to do is search anything on google from the usa or canada.
(unknown) 8/26/14 6:05 AM <This message has been deleted.>
Re: Glitch? GraceFull Fred 8/26/14 6:09 AM
South America too
Re: Glitch? Bam240 8/26/14 6:15 AM
I am also having the same problem on my home network as well as my cell phone network which is different than my home network.
Re: Glitch? mjr85 8/26/14 6:15 AM
I'm in Canada and the same thing is happening on my laptop, desktop and iPhone. I've been really freaking out about this all morning and have no idea what the problem is!! Anyone figure this out yet? I've done a malware check, etc. and nothing came up. Is this happening with everyone using google? I
Re: Glitch? Andrew Klinedinst 8/26/14 6:20 AM
Thanks for the info! +1. failed to replicate the results on my machine. Trying to get some more data from around, though your reply makes me think I may be on the right track here.
Re: Glitch? Nick Barkley 8/26/14 6:23 AM
Same situation for me here in Canada (Rogers)- Car crash photo.
Could it be something related to my Android phone over WiFi?  Just a guess...

Re: Glitch? Gibblers Dad 8/26/14 6:24 AM
The problem can be replicated by using Google's public DNS servers at either or and flushing your DNS cache. It can be corrected by using another DNS server, other than Google's, in your settings and again flushing the DNS cache. The problem appears to be directly related to their DNS here.
Re: Glitch? Chris Plosaj 8/26/14 6:27 AM
Same issue here in Canada. Really annoying.
Re: Glitch? Andrew Klinedinst 8/26/14 6:27 AM
I'm wondering if this goes up to a top level root server and not just google's open DNS.  Too few people use it for it to be this widespread and yet regional.
Re: Glitch? Shannon... 8/26/14 6:29 AM
Re: Glitch? Janet Grissett 8/26/14 6:30 AM
tried changing DNS but same results. However, it is not happening on every search. Only intermittent now. Some searches work fine--others do not.
Re: Glitch? Sergio De Lara 8/26/14 6:35 AM
Except for the fact that when you click on any of those images, the "real" one appears instead. So it's not actually taking you to anything about that crash.
Eerie indeed.
Re: Glitch? Gibblers Dad 8/26/14 6:36 AM
Does work reliably here, providing you run "ipconfig /flushdns" at a command prompt after the change.  Also should note that you may need to change any intermediary device (router) as well as your client, and flushing DNS in a router is usually simply a reboot.
Re: Glitch? Sheppy99 8/26/14 6:38 AM

news is starting to report it now it looks like......

Re: Glitch? Kelly Machado 8/26/14 6:38 AM
Hi guys,

Thank you all for your reports! Just to let you know that we are currently looking into this.

We will keep you updated on this thread.


Re: Glitch? Edson Minatti 8/26/14 6:44 AM
The same thing is happening down here in Brazil...
(unknown) 8/26/14 6:45 AM <This message has been deleted.>
Re: Glitch? Chris Plosaj 8/26/14 6:52 AM
Googlenet has become self-aware.
We must send you back Kevin Durant. Only you can stop this. Find Sergey Brin. You know what must be done.
Re: Glitch? Karl BOW 8/26/14 6:54 AM
Re: Glitch? flynngrrl 8/26/14 6:56 AM
Same here. Pic attached.
Re: Glitch? Adelyne Débora 8/26/14 7:01 AM
News are finally starting to spread the happening.
People are reporting the same issue in different browsers too.
Only Bing is working fine and is really something annoying, sad and wrong all this disrespect public internet users are suffering because of political issues. It creeps a bit the fact the only word readable in the image means "Stop" I will star to use deep web if regular internet start to be a media of war even if it's cold war.
I'm not part of this.
Re: Glitch? Frog Stew 8/26/14 7:06 AM
Me too! Same image!
(unknown) 8/26/14 7:07 AM <This message has been deleted.>
Re: Glitch? Thalles Felipe 8/26/14 7:09 AM
Hi Guys!

I changed the DNS server and cleared DNS cache also, it's working now.

Actually I'm using OpenDNS:


Re: Glitch? Sharline Harrilal 8/26/14 7:16 AM
I'm having the same problem in Trinidad and Tobago.
Re: Glitch? Josiel 8/26/14 7:18 AM
Hey dude, I got the same!
Re: Glitch? Josiel 8/26/14 7:18 AM
Re: Glitch? bbrite1025 8/26/14 7:21 AM
In the last 7 minutes images went from only the car crash to car crash and kevin durant
Re: Glitch? EricS123456 8/26/14 7:22 AM
Seems to be fixed. (from Boston, MA)


Re: Glitch? Marco Vaz 8/26/14 7:22 AM
Also in Brazil. It's intermittent.

Protest against car manufacturer?

Re: Glitch? Sylvain Senechal 8/26/14 7:24 AM
Fixed here in Canada.
Juste clear the browsers cache
Re: Glitch? Raven's Child 8/26/14 7:25 AM
Mine is fine now too.
Re: Glitch? semunky 8/26/14 7:26 AM
I have had this problem since 7am EST when I started trying to finish my paper and needed medical images for portions.

I have noticed the first search upon opening a new browser will give me several lines of appropriate images before the occasional car crash is put in.

any subsequent search will result in 2 lines of pertinent images and then the start of repeated car crash images.  I can click on the image though and see what I was trying to look at, but its way too tedious to click on each image and try to see what its real image is supposed to be.  Also I'm uncertain if doing so is a problem-perpetuating the issue-or exposing me to potential downloaded threats.

Re: Glitch? Raven's Child 8/26/14 7:28 AM
Mine simply fixed it self no work needed.
Re: Glitch? Sheppy99 8/26/14 7:29 AM
Mine is fixed too. Just cleared my browser and restarted. All is fine again.

Thanks google for taking care of that annoying problem.

Re: Glitch? mjr85 8/26/14 7:29 AM
Mine seems to be working again. Still would like to know why this was happening (and only to select people)! Hopefully this isn't a sign of a bigger problem....
Re: Glitch? Janet Grissett 8/26/14 7:32 AM
NOT fixed for me yet. Still intermittent. Cleared cache, cleared DNS, restarted, etc. etc. etc. still persists intermittent
Re: Glitch? Publius of Maryland 8/26/14 7:34 AM
Looks like the problem was resolved. I'm not seeing the issue any longer.
Re: Glitch? Kelly Machado 8/26/14 7:35 AM
Hey guys,

We think we've fixed it. Could you please try and refresh your browser (clear cache & cookies) and see if it worked for you?

Thank you,
Re: Glitch? Janet Grissett 8/26/14 7:39 AM
found this blog from 2011 that seems to describe exactly what is happening. BUT NO
Re: Glitch? Janet Grissett 8/26/14 7:40 AM
found this blog from 2011 that seems to describe exactly what is happening BUT not how to fix from user's end
Re: Glitch? Rafael Chaves 8/26/14 7:41 AM
Saw also a similar issue with Google Viewer, documented in attachment (any attachment being previewed in Gmail, when popped-out, would show as unrelated but fixed content). It appears to be fixed now.
Re: Glitch? Renton Thurston 8/26/14 7:42 AM
Thanks. United States with Cox Communications as my ISP.

Problem seems to be completely resolved. As I suspected, probably something on Google's end, not on the user end.

Re: Glitch? mjr85 8/26/14 7:42 AM
Kelly: Why was this happening? It seems to be fixed on my computers and phone. Should we be worried if our computers were effected by this?
Re: Glitch? Philipp Christoph 8/26/14 7:43 AM
Germany here, it's getting better, but about 50% of all images still show the car crash.
Re: Glitch? Dan Deibler 8/26/14 7:44 AM
It appears to be fixed for Images, but the problem continues to exist for News thumbnails.
Re: Glitch? ddd_br 8/26/14 7:46 AM
Now it's working fine here (Brazil), even without cache/dns cleaning. Just refreshed page using Google Chrome.

For those who still have problems, you may call your ISP or your network administrator, many private network still have proxy caches that may still need to be cleared.

Kelly, technically speaking, what was the problem after all?

Re: Glitch? Alexandre Queiroga 8/26/14 7:50 AM
Not fixed to me. The same problem with images and showing the same car - I'm at South America , Brazil.
Re: Glitch? andreblanchard 8/26/14 7:55 AM
image search engine fixed here now ty so much


Re: Glitch? Alexandre Queiroga 8/26/14 7:57 AM
Finally solved for me:) Thank you !
Re: Glitch? Alex Diotte 8/26/14 7:58 AM
Still showing up for me on win7 x64. Also on galaxy S3. Not showing up on my wifes' win8 x64 pc, or her galaxy S3. Any other information that could help in resolving the issue...?
Re: Glitch? Shannon... 8/26/14 7:58 AM
Hello Alexandre,

From Kelly Muchado, Google Employee,

"We think we've fixed it. Could you please try and refresh your browser (clear cache & cookies) and see if it worked for you?"


Re: Glitch? J. Fernando Martinez 8/26/14 8:00 AM
I just checked its working fine now in Google Uruguay.
Re: Glitch? Colton Toney 8/26/14 8:01 AM
Use incognito mode, until Google fixes it.

How to-

Re: Glitch? Gibblers Dad 8/26/14 8:10 AM
Confirming problem is definitely resolved here. Appreciate the work of the Google folks in addressing the issue. Would also be curious about the cause as well...

Thank you for the updates Kelly.

Re: Glitch? A Cuthbertson 8/26/14 8:11 AM
Hi Kelly,
Do you have any idea what might have caused this glitch?
Anthony (tech journalist, IBTimes UK)
Re: Glitch? John Vedder 8/26/14 8:14 AM
I confirmed that it appears to be a DNS issue.  It affected all browsers (Chrome, FireFox, Safari) on all PC's in my home.  The problem persisted until I rebooted my router AND cleared the cache in each web browser. Steps I took to fix it:

1. Turn off the PC.
2. Turn my router off and on.
3. Turn on the PC.
4. From a command prompt as administrator, I ran this command to clear ARP cache.  Rebooting should have cleared this, but I did this anyway.

    netsh interface ip delete arpcache

4. Clear the cache in each web browser on each PC.  See here:

Re: Glitch? nealem 8/26/14 8:24 AM
Hi A Cuthbertson, 

Thanks for your question. At the moment we have nothing to share beyond that it's a technical issue on our end. Please feel free to reach out to

Re: Glitch? IGORKRN 8/26/14 8:29 AM
same problem here, simply an "issue on our end" is probably an attack of Ukrainian or Russian hackers
Re: Glitch? Janet Grissett 8/26/14 9:23 AM
after 3 hours of clearing, deleting, and running malware, spyware, and anti-virus, which found a boatload of crud not there at last scan, the problem is finally resolved for me.
Re: Glitch? Matthew Villani 8/26/14 9:33 AM
I'm glad to hear the problem's being fixed. I'm also happy to know that it's not just me and a couple other people, I thought maybe I had a virus. I tried running every antivirus program I had and kept getting nothing. While I'm still getting some results showing the crashed garbage truck, at least it's no longer appearing as every result after the sixth image shown.
Re: Glitch? Bruno Hollweg 8/26/14 9:37 AM
It was hacked by palestins hackers and they say google earth going to be hacked soon chanching the ñame of Israel for palestin
Re: Glitch? Cody 923 8/26/14 9:47 AM
less bad immages, but there are still some....what was the problem...was google hacked...or will google never admit that someone managed to hack them.  
Re: Glitch? Bruno Hollweg 8/26/14 9:56 AM
Of course they never gonna admit  they called a "glitch" but there's was not "glitch" google was hacked. And Google Earth is next.
Re: Glitch? Sarah Cartwright 8/26/14 11:38 AM
What was it, Kelly?
Re: Glitch? Toby Rosebrugh 8/26/14 1:42 PM
I am still seeing that image in some of my searches for some strange reason.
Re: Glitch? Adelyne Débora 8/26/14 2:11 PM
Not working fine here in Brazil.
Still the same thing. MORE than 12 hours and Google didn't fixed or gave some statement for media or for people here. Seriously. What if they hack some personal content? This damn thing is starting to be annoying. Mature real men solve stuff like men. Not as stupid people with this stupid cold war using people. I'm not part of this. Russia, Ucraine... USA... they should become better places and show this by actions not stupid attitudes.
Re: Glitch? Toby Rosebrugh 8/26/14 2:27 PM
It's partially fixed on my PC but not on my phone unfortunately.
Re: Glitch? Feelingwalnut 8/26/14 3:33 PM
clear all browsing information in your phone.
Re: Glitch? Dan9 8/26/14 5:00 PM
yaaaay thanks
Re: Glitch? Abdul001 8/26/14 9:54 PM
Was that just a technical issue???
Re: Glitch? Adelyne Débora 8/27/14 7:26 AM
Only now it's ok here. If someone still having this problem, try to clear cache and cookies and open the browser again.
Re: Glitch? Jeany Jansen 8/27/14 7:39 AM
Yes all OK again since yesterday afternoon.
This message has been hidden because it was flagged for abuse.
Move photos from Apple to Google Marian Simpson 9/2/14 2:35 PM <This message has been deleted.>
Re: Move photos from Apple to Google Amal Sk 9/2/14 11:28 PM <This message has been deleted.>
This message has been hidden because it was flagged for abuse.
This message has been hidden because it was flagged for abuse.
This message has been hidden because it was flagged for abuse.
This message has been hidden because it was flagged for abuse.
This message has been hidden because it was flagged for abuse.
This message has been hidden because it was flagged for abuse.
More topics »