Categories: Problems and Errors : Linux :

Installation error

Showing 1-14 of 14 messages
Installation error Albald 2/3/10 1:43 PM
On Debian Squeeze, I downloaded installation file, but I have this error:


$  Desktop/GoogleEarthLinux.bin
Verifying archive integrity... All good.
Uncompressing Google Earth for GNU/Linux 5.1.3533.1731...............................................................
setup.data/setup.xml:1: parser error : Document is empty

^
setup.data/setup.xml:1: parser error : Start tag expected, '<' not found

^
Impossibile caricare 'setup.data/setup.xml'
Re: Installation error habtool 2/5/10 4:19 AM
Hi
I was having the same error when trying to install from the bin file from google.
(Did not find a direct solution to that issue)

Make sure you have contrib enable in your sources file:
deb http://ftp.debian.org/debian/ testing main contrib non-free

Then:
sudo apt-get update
sudo apt-get install googleearth-package
then in the terminal type:
make-googleearth-package

that will download a file from google and compile a deb for you
You then need to install the deb that it makes:
At the same terminal as above type:
sudo dpkg -i googleearth*.deb
Re: Installation error bvidinli 8/31/10 3:04 PM
worked very nice, thanks.
Re: Installation error Strawp 11/30/10 2:28 PM
Fantastic, that worked on 6 too
Re: Installation error QkiZ 12/1/10 9:27 AM
Building deb package doesn't help. Google Earth 6 installs but not starting. When i run program from terminal i got error:
/usr/lib/googleearth/googleearth-bin: File not exist.
But file exist in this path and have execute bit.
Re: Installation error Earth PM Peter 12/9/10 12:53 AM
The problem reported by Albald is likely due to an incompatible GTK.  We have seen this on some distros.  We are looking into and hopefully will be able to resolve the issue soon.

Sorry for the inconvenience,

peter
Re: Installation error Arié 12/13/10 4:30 PM
@QkiZ: sudo apt-get install lsb-core ;)
Re: Installation error brillot 12/14/10 4:29 AM
for me, the solution is : http://www.webupd8.org/2010/11/install-google-earth-6-in-ubuntu-linux.html
Re: Installation error Earth PM Peter 12/22/10 2:43 PM
Hi,

We have recently changed our Linux installers to hopefully address these types of issues.  For those of you still having problems, please try going back to earth.google.com and reinstalling.

thanks,

peter
Re: Installation error AlgorithMan 1/9/11 10:10 AM
I still get the
> setup.data/setup.xml:1: parser error : Document is empty
> setup.data/setup.xml:1: parser error : Start tag expected, '<' not found
error on newest, fully patched kubuntu with newest google earth.

I cannot install through package sources, because they still have 5.1.3533.1731

http://www.webupd8.org/2010/11/install-google-earth-6-in-ubuntu-linux.html
didn't help either, because /tmp/ge doesn't exist

lsb-core is installed. still nothing
Re: Installation error AlgorithMan 1/9/11 10:53 AM
this is getting weird. using
./GoogleEarthLinux.bin --target /tmp/ge
I got the files to /tmp/ge, but there is no setup.gtk. Instead there is a setup.gtk2.glade

so I installed glade and gtk2 (*yuck*) and I still get the same error (setup.data/setup.xml
document empty), ALTHOUGH the file setup.xml is there AND it contains the XML-Tag
opening bracket < AND I have read access to it

why do you provide a binary installer (windows style installation) in the first place?
Re: Installation error AlgorithMan 1/9/11 2:13 PM
okay, so I found out that googleearth-package had not been updated, although reinstalling it now got me version 6...
that's weird - things that are installed through package-sources should not behave like this (not your fault though)
the font is crappy, but I'm happy with the performance and overall look & feel of the 3d view.
anyhow - when I found that out, I already had my own installer bashscript finished - so if anyone ever needs this:
#!/bin/bash
if [ "$UID" != 0 ]; then
echo "need root privileges"
exit 1
fi
if ! [ -f ./GoogleEarthLinux.bin ]; then
echo "GoogleEarthLinux.bin not found"
exit 1
fi
echo "unpacking installation files"
chmod +x ./GoogleEarthLinux.bin
./GoogleEarthLinux.bin --target /tmp/ge >/dev/null 2>&1
echo "installing"
mkdir /usr/lib/googleearth
cd /usr/lib/googleearth
tar -xf /tmp/ge/googleearth-data.tar >/dev/null 2>&1
tar -xf /tmp/ge/googleearth-linux-x86.tar >/dev/null 2>&1
echo "installing wrapper-script"
cat >/usr/bin/googleearth << HERE
#!/bin/sh
if [ ! -z "$LD_LIBRARY_PATH" ]; then
SEP=":"
fi
export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}${SEP}/usr/lib/googleearth
/usr/lib/googleearth/googleearth-bin "$@"
HERE
chmod a+x /usr/bin/googleearth
echo "installing icons"
cd /tmp/ge/desktop_icons/consumer/
for f in product_logo_*.png; do \
size=$(echo $f | sed s/product_logo_// | sed s/.png//); \
if [ -d /usr/share/icons/oxygen/${size}x${size}/apps ]; then
cp $f /usr/share/icons/oxygen/${size}x${size}/apps/googleearth.png; \
chmod a+r /usr/share/icons/oxygen/${size}x${size}/apps/googleearth.png; \
fi
done
echo "removing installation files"
rm -rf /tmp/ge
and for uninstalling
#!/bin/bash
if [ "$UID" != 0 ]; then
echo "need root privileges"
exit 1
fi
rm -rf /usr/lib/googleearth
rm -f /usr/bin/googleearth
cd /usr/share/icons/oxygen
for d in *; do
if [ -d "$d" ]; then
rm -f $d/apps/googleearth.png
fi
done
Re: Installation error robertlipe 1/13/11 10:39 AM
The issue in the OP is no longer an issue with the deb/rpm packaged versions released in mid December of 2010.  A manual apt-get install lsb-core may still be needed for minimally configured systems.

the steps described by AlgorithMan are performed by the package installers in the 6.0.1/December builds.
Re: Installation error StrongGale 12/4/12 11:58 PM
Hi there,

Ubuntu 12.10 amd64

I downloaded the file google-earth-stable_current_amd64.deb from google and tried to install it as a deb package through Ubuntu Software Center
I received the following warning:

The installation of a package which violates the quality standards isn't allowed.
This could cause serious problems on your computer.
Please contact the person or organisation who provided this package file and include the details beneath.


I am a bit shy at taking chances of serious damage when forcing the process from command line.

What would anyone suggest?

Thank you in advance