Categories: Report an Issue :

I keep getting a message, "Bad Request".

Showing 1-58 of 58 messages
I keep getting a message, "Bad Request". WiiKid360 3/16/09 4:55 PM
I keep getting it when I click on a link. What does it mean and how do I fix it?
Re: I keep getting a message, "Bad Request". agl 3/17/09 3:21 PM
We're looking for a technically competent user to help debug this issue. So far, nobody who has reported this problem has actually responded.
Re: I keep getting a message, "Bad Request". WiiKid360 3/17/09 3:22 PM
Well I think I can help.
Re: I keep getting a message, "Bad Request". agl 3/17/09 4:18 PM
Ok, I'll need:

  * the version of chrome (about:version)
  * in Chrome, can you go to http://zool.imperialviolet.org:4545/YourUsernameHere (replace the last bit obviously). It won't do anything, but it'll log the headers used. Sadly, random people end up clicking these links, and it only logs the first person.

Let's start with that.
Re: I keep getting a message, "Bad Request". WiiKid360 3/17/09 5:14 PM
Version - 2.0.169.1

Ok i went to the site, but it said the site might be temporarily down, or moved.
Re: I keep getting a message, "Bad Request". agl 3/17/09 5:15 PM
Ok, somebody hit that link with your username. (If it wasn't you, please say so). Next, can you please give a website which fails in an obviously bad way?
Re: I keep getting a message, "Bad Request". WiiKid360 3/17/09 5:20 PM
I may have hit that link when I was browsing the help pages, and replaced the end. I can't think of any website that fail, but some ads have had that error. Also current.com seems funny to me.
Re: I keep getting a message, "Bad Request". WiiKid360 3/17/09 5:21 PM
This is what it says:

ERROR

The requested URL could not be retrieved

While trying to retrieve the URL: http://current.com/

The following error was encountered:

Invalid URL
Some aspect of the requested URL is incorrect. Possible problems:

Missing or incorrect access protocol (should be `http://'' or similar)
Missing hostname
Illegal double-escape in the URL-Path
Illegal character in hostname; underscores are not allowed
Your cache administrator is root.
Generated Wed, 18 Mar 2009 00:19:37 GMT by sfprdsquid04.sfcolo.current.com (squid/3.0.STABLE7)
Re: I keep getting a message, "Bad Request". agl 3/17/09 5:34 PM
From the connection log from zool.imperialviolet.org I can recreate the request and reply to to current.com, and everything is fine. Can you confirm that, when you type "http://current.com" into the URL, that "Invalid URL" message is what you get? Everytime? Do you know how to use a sniffer?
Re: I keep getting a message, "Bad Request". WiiKid360 3/17/09 5:36 PM
It happens every time for me, and I can't use a sniffer.
Re: I keep getting a message, "Bad Request". agl 3/17/09 5:44 PM
Can you goto "view-cache:", git Ctrl-F and find "http://current.com"? Click that link and paste the output for the top three seconds (where the sections are marked by a horizontal line).

Also, click "Start", "Run..", type in "cmd", enter, type "tracert current.com" and paste the output from that too.



Cheers
Re: I keep getting a message, "Bad Request". WiiKid360 3/17/09 5:53 PM
What do you mean by top three seconds.
Re: I keep getting a message, "Bad Request". agl 3/17/09 5:54 PM
Sorry, top three sections.
Re: I keep getting a message, "Bad Request". WiiKid360 3/17/09 5:55 PM
Oh ok.

HTTP/1.1 400 Bad Request
Server: squid/3.0.STABLE7
Mime-Version: 1.0
Date: Wed, 18 Mar 2009 00:37:07 GMT
Content-Type: text/html
Content-Length: 1492
Expires: Wed, 18 Mar 2009 00:37:07 GMT
X-Squid-Error: ERR_INVALID_URL 0
X-Cache: MISS from sfprdsquid02.sfcolo.current.com
X-Cache-Lookup: NONE from sfprdsquid02.sfcolo.current.com:3128
Via: 1.0 sfprdsquid02.sfcolo.current.com (squid/3.0.STABLE7)
X-OSSProxy: OSSProxy 1.3.322.344 (Build 322.344 Win32 en-us)(Mar  9 2009 09:48:50)
00000000:  f9  01  00  00  01  00  00  00  c6  97  b3  2a  f0  c3  2d  00  ...........*..-.
00000010:  0e  7a  b6  2a  f0  c3  2d  00  e1  01  00  00  48  54  54  50  .z.*..-.....HTTP
00000020:  2f  31  2e  31  20  34  30  30  20  42  61  64  20  52  65  71  /1.1 400 Bad Req
00000030:  75  65  73  74  00  53  65  72  76  65  72  3a  20  73  71  75  uest.Server: squ
00000040:  69  64  2f  33  2e  30  2e  53  54  41  42  4c  45  37  00  4d  id/3.0.STABLE7.M
00000050:  69  6d  65  2d  56  65  72  73  69  6f  6e  3a  20  31  2e  30  ime-Version: 1.0
00000060:  00  44  61  74  65  3a  20  57  65  64  2c  20  31  38  20  4d  .Date: Wed, 18 M
00000070:  61  72  20  32  30  30  39  20  30  30  3a  33  37  3a  30  37  ar 2009 00:37:07
00000080:  20  47  4d  54  00  43  6f  6e  74  65  6e  74  2d  54  79  70   GMT.Content-Typ
00000090:  65  3a  20  74  65  78  74  2f  68  74  6d  6c  00  43  6f  6e  e: text/html.Con
000000a0:  74  65  6e  74  2d  4c  65  6e  67  74  68  3a  20  31  34  39  tent-Length: 149
000000b0:  32  00  45  78  70  69  72  65  73  3a  20  57  65  64  2c  20  2.Expires: Wed,
000000c0:  31  38  20  4d  61  72  20  32  30  30  39  20  30  30  3a  33  18 Mar 2009 00:3
000000d0:  37  3a  30  37  20  47  4d  54  00  58  2d  53  71  75  69  64  7:07 GMT.X-Squid
000000e0:  2d  45  72  72  6f  72  3a  20  45  52  52  5f  49  4e  56  41  -Error: ERR_INVA
000000f0:  4c  49  44  5f  55  52  4c  20  30  00  58  2d  43  61  63  68  LID_URL 0.X-Cach
00000100:  65  3a  20  4d  49  53  53  20  66  72  6f  6d  20  73  66  70  e: MISS from sfp
00000110:  72  64  73  71  75  69  64  30  32  2e  73  66  63  6f  6c  6f  rdsquid02.sfcolo
00000120:  2e  63  75  72  72  65  6e  74  2e  63  6f  6d  00  58  2d  43  .current.com.X-C
00000130:  61  63  68  65  2d  4c  6f  6f  6b  75  70  3a  20  4e  4f  4e  ache-Lookup: NON
00000140:  45  20  66  72  6f  6d  20  73  66  70  72  64  73  71  75  69  E from sfprdsqui
00000150:  64  30  32  2e  73  66  63  6f  6c  6f  2e  63  75  72  72  65  d02.sfcolo.curre
00000160:  6e  74  2e  63  6f  6d  3a  33  31  32  38  00  56  69  61  3a  nt.com:3128.Via:
00000170:  20  31  2e  30  20  73  66  70  72  64  73  71  75  69  64  30   1.0 sfprdsquid0
00000180:  32  2e  73  66  63  6f  6c  6f  2e  63  75  72  72  65  6e  74  2.sfcolo.current
00000190:  2e  63  6f  6d  20  28  73  71  75  69  64  2f  33  2e  30  2e  .com (squid/3.0.
000001a0:  53  54  41  42  4c  45  37  29  00  58  2d  4f  53  53  50  72  STABLE7).X-OSSPr
000001b0:  6f  78  79  3a  20  4f  53  53  50  72  6f  78  79  20  31  2e  oxy: OSSProxy 1.
000001c0:  33  2e  33  32  32  2e  33  34  34  20  28  42  75  69  6c  64  3.322.344 (Build
000001d0:  20  33  32  32  2e  33  34  34  20  57  69  6e  33  32  20  65   322.344 Win32 e
000001e0:  6e  2d  75  73  29  28  4d  61  72  20  20  39  20  32  30  30  n-us)(Mar  9 200
000001f0:  39  20  30  39  3a  34  38  3a  35  30  29  20  00              9 09:48:50) .
00000000:  3c  21  44  4f  43  54  59  50  45  20  48  54  4d  4c  20  50  <!DOCTYPE HTML P
00000010:  55  42  4c  49  43  20  22  2d  2f  2f  57  33  43  2f  2f  44  UBLIC "-//W3C//D
00000020:  54  44  20  48  54  4d  4c  20  34  2e  30  31  20  54  72  61  TD HTML 4.01 Tra
00000030:  6e  73  69  74  69  6f  6e  61  6c  2f  2f  45  4e  22  20  22  nsitional//EN" "
00000040:  68  74  74  70  3a  2f  2f  77  77  77  2e  77  33  2e  6f  72  http://www.w3.or
00000050:  67  2f  54  52  2f  68  74  6d  6c  34  2f  6c  6f  6f  73  65  g/TR/html4/loose
00000060:  2e  64  74  64  22  3e  0a  3c  48  54  4d  4c  3e  3c  48  45  .dtd">.<HTML><HE
00000070:  41  44  3e  3c  4d  45  54  41  20  48  54  54  50  2d  45  51  AD><META HTTP-EQ
00000080:  55  49  56  3d  22  43  6f  6e  74  65  6e  74  2d  54  79  70  UIV="Content-Typ
00000090:  65  22  20  43  4f  4e  54  45  4e  54  3d  22  74  65  78  74  e" CONTENT="text
000000a0:  2f  68  74  6d  6c  3b  20  63  68  61  72  73  65  74  3d  69  /html; charset=i
000000b0:  73  6f  2d  38  38  35  39  2d  31  22  3e  0a  3c  54  49  54  so-8859-1">.<TIT
000000c0:  4c  45  3e  45  52  52  4f  52  3a  20  54  68  65  20  72  65  LE>ERROR: The re
000000d0:  71  75  65  73  74  65  64  20  55  52  4c  20  63  6f  75  6c  quested URL coul
000000e0:  64  20  6e  6f  74  20  62  65  20  72  65  74  72  69  65  76  d not be retriev
000000f0:  65  64  3c  2f  54  49  54  4c  45  3e  0a  3c  53  54  59  4c  ed</TITLE>.<STYL
00000100:  45  20  74  79  70  65  3d  22  74  65  78  74  2f  63  73  73  E type="text/css
00000110:  22  3e  3c  21  2d  2d  42  4f  44  59  7b  62  61  63  6b  67  "><!--BODY{backg
00000120:  72  6f  75  6e  64  2d  63  6f  6c  6f  72  3a  23  66  66  66  round-color:#fff
00000130:  66  66  66  3b  66  6f  6e  74  2d  66  61  6d  69  6c  79  3a  fff;font-family:
00000140:  76  65  72  64  61  6e  61  2c  73  61  6e  73  2d  73  65  72  verdana,sans-ser
00000150:  69  66  7d  50  52  45  7b  66  6f  6e  74  2d  66  61  6d  69  if}PRE{font-fami
00000160:  6c  79  3a  73  61  6e  73  2d  73  65  72  69  66  7d  2d  2d  ly:sans-serif}--
00000170:  3e  3c  2f  53  54  59  4c  45  3e  0a  3c  2f  48  45  41  44  ></STYLE>.</HEAD
00000180:  3e  3c  42  4f  44  59  3e  0a  3c  48  31  3e  45  52  52  4f  ><BODY>.<H1>ERRO
00000190:  52  3c  2f  48  31  3e  0a  3c  48  32  3e  54  68  65  20  72  R</H1>.<H2>The r
000001a0:  65  71  75  65  73  74  65  64  20  55  52  4c  20  63  6f  75  equested URL cou
000001b0:  6c  64  20  6e  6f  74  20  62  65  20  72  65  74  72  69  65  ld not be retrie
000001c0:  76  65  64  3c  2f  48  32  3e  0a  3c  48  52  20  6e  6f  73  ved</H2>.<HR nos
000001d0:  68  61  64  65  20  73  69  7a  65  3d  22  31  70  78  22  3e  hade size="1px">
000001e0:  0a  3c  50  3e  0a  57  68  69  6c  65  20  74  72  79  69  6e  .<P>.While tryin
000001f0:  67  20  74  6f  20  72  65  74  72  69  65  76  65  20  74  68  g to retrieve th
00000200:  65  20  55  52  4c  3a  0a  3c  41  20  48  52  45  46  3d  22  e URL:.<A HREF="
00000210:  68  74  74  70  3a  2f  2f  63  75  72  72  65  6e  74  2e  63  http://current.c
00000220:  6f  6d  2f  22  3e  68  74  74  70  3a  2f  2f  63  75  72  72  om/">http://curr
00000230:  65  6e  74  2e  63  6f  6d  2f  3c  2f  41  3e  0a  3c  50  3e  ent.com/</A>.<P>
00000240:  0a  54  68  65  20  66  6f  6c  6c  6f  77  69  6e  67  20  65  .The following e
00000250:  72  72  6f  72  20  77  61  73  20  65  6e  63  6f  75  6e  74  rror was encount
00000260:  65  72  65  64  3a  0a  3c  55  4c  3e  0a  3c  4c  49  3e  0a  ered:.<UL>.<LI>.
00000270:  3c  53  54  52  4f  4e  47  3e  0a  49  6e  76  61  6c  69  64  <STRONG>.Invalid
00000280:  20  55  52  4c  0a  3c  2f  53  54  52  4f  4e  47  3e  0a  3c   URL.</STRONG>.<
00000290:  2f  55  4c  3e  0a  0a  3c  50  3e  0a  53  6f  6d  65  20  61  /UL>..<P>.Some a
000002a0:  73  70  65  63  74  20  6f  66  20  74  68  65  20  72  65  71  spect of the req
000002b0:  75  65  73  74  65  64  20  55  52  4c  20  69  73  20  69  6e  uested URL is in
000002c0:  63  6f  72  72  65  63  74  2e  20  20  50  6f  73  73  69  62  correct.  Possib
000002d0:  6c  65  20  70  72  6f  62  6c  65  6d  73  3a  0a  3c  55  4c  le problems:.<UL
000002e0:  3e  0a  3c  4c  49  3e  4d  69  73  73  69  6e  67  20  6f  72  >.<LI>Missing or
000002f0:  20  69  6e  63  6f  72  72  65  63  74  20  61  63  63  65  73   incorrect acces
00000300:  73  20  70  72  6f  74  6f  63  6f  6c  20  28  73  68  6f  75  s protocol (shou
00000310:  6c  64  20  62  65  20  60  68  74  74  70  3a  2f  2f  27  27  ld be `http://''
00000320:  20  6f  72  20  73  69  6d  69  6c  61  72  29  0a  3c  4c  49   or similar).<LI
00000330:  3e  4d  69  73  73  69  6e  67  20  68  6f  73  74  6e  61  6d  >Missing hostnam
00000340:  65  0a  3c  4c  49  3e  49  6c  6c  65  67  61  6c  20  64  6f  e.<LI>Illegal do
00000350:  75  62  6c  65  2d  65  73  63  61  70  65  20  69  6e  20  74  uble-escape in t
00000360:  68  65  20  55  52  4c  2d  50  61  74  68  0a  3c  4c  49  3e  he URL-Path.<LI>
00000370:  49  6c  6c  65  67  61  6c  20  63  68  61  72  61  63  74  65  Illegal characte
00000380:  72  20  69  6e  20  68  6f  73  74  6e  61  6d  65  3b  20  75  r in hostname; u
00000390:  6e  64  65  72  73  63  6f  72  65  73  20  61  72  65  20  6e  nderscores are n
000003a0:  6f  74  20  61  6c  6c  6f  77  65  64  0a  3c  2f  55  4c  3e  ot allowed.</UL>
000003b0:  0a  3c  50  3e  59  6f  75  72  20  63  61  63  68  65  20  61  .<P>Your cache a
000003c0:  64  6d  69  6e  69  73  74  72  61  74  6f  72  20  69  73  20  dministrator is
000003d0:  3c  41  20  48  52  45  46  3d  22  6d  61  69  6c  74  6f  3a  <A HREF="mailto:
000003e0:  72  6f  6f  74  3f  73  75  62  6a  65  63  74  3d  43  61  63  root?subject=Cac
000003f0:  68  65  45  72  72  6f  72  49  6e  66  6f  25  32  30  2d  25  heErrorInfo%20-%
00000400:  32  30  45  52  52  5f  49  4e  56  41  4c  49  44  5f  55  52  20ERR_INVALID_UR
00000410:  4c  26  61  6d  70  3b  62  6f  64  79  3d  43  61  63  68  65  L&amp;body=Cache
00000420:  48  6f  73  74  25  33  41  25  32  30  73  66  70  72  64  73  Host%3A%20sfprds
00000430:  71  75  69  64  30  32  2e  73  66  63  6f  6c  6f  2e  63  75  quid02.sfcolo.cu
00000440:  72  72  65  6e  74  2e  63  6f  6d  25  30  44  25  30  41  45  rrent.com%0D%0AE
00000450:  72  72  50  61  67  65  25  33  41  25  32  30  45  52  52  5f  rrPage%3A%20ERR_
00000460:  49  4e  56  41  4c  49  44  5f  55  52  4c  25  30  44  25  30  INVALID_URL%0D%0
00000470:  41  45  72  72  25  33  41  25  32  30  25  35  42  6e  6f  6e  AErr%3A%20%5Bnon
00000480:  65  25  35  44  25  30  44  25  30  41  54  69  6d  65  53  74  e%5D%0D%0ATimeSt
00000490:  61  6d  70  25  33  41  25  32  30  57  65  64  2c  25  32  30  amp%3A%20Wed,%20
000004a0:  31  38  25  32  30  4d  61  72  25  32  30  32  30  30  39  25  18%20Mar%202009%
000004b0:  32  30  30  30  25  33  41  33  37  25  33  41  30  37  25  32  2000%3A37%3A07%2
000004c0:  30  47  4d  54  25  30  44  25  30  41  25  30  44  25  30  41  0GMT%0D%0A%0D%0A
000004d0:  43  6c  69  65  6e  74  49  50  25  33  41  25  32  30  31  39  ClientIP%3A%2019
000004e0:  32  2e  31  36  38  2e  32  30  31  2e  31  25  30  44  25  30  2.168.201.1%0D%0
000004f0:  41  25  30  44  25  30  41  48  54  54  50  25  32  30  52  65  A%0D%0AHTTP%20Re
00000500:  71  75  65  73  74  25  33  41  25  30  44  25  30  41  25  30  quest%3A%0D%0A%0
00000510:  44  25  30  41  25  30  44  25  30  41  22  3e  72  6f  6f  74  D%0A%0D%0A">root
00000520:  3c  2f  41  3e  2e  20  0a  0a  3c  42  52  20  63  6c  65  61  </A>. ..<BR clea
00000530:  72  3d  22  61  6c  6c  22  3e  0a  3c  48  52  20  6e  6f  73  r="all">.<HR nos
00000540:  68  61  64  65  20  73  69  7a  65  3d  22  31  70  78  22  3e  hade size="1px">
00000550:  0a  3c  41  44  44  52  45  53  53  3e  0a  47  65  6e  65  72  .<ADDRESS>.Gener
00000560:  61  74  65  64  20  57  65  64  2c  20  31  38  20  4d  61  72  ated Wed, 18 Mar
00000570:  20  32  30  30  39  20  30  30  3a  33  37  3a  30  37  20  47   2009 00:37:07 G
00000580:  4d  54  20  62  79  20  73  66  70  72  64  73  71  75  69  64  MT by sfprdsquid
00000590:  30  32  2e  73  66  63  6f  6c  6f  2e  63  75  72  72  65  6e  02.sfcolo.curren
000005a0:  74  2e  63  6f  6d  20  28  73  71  75  69  64  2f  33  2e  30  t.com (squid/3.0
000005b0:  2e  53  54  41  42  4c  45  37  29  0a  3c  2f  41  44  44  52  .STABLE7).</ADDR
000005c0:  45  53  53  3e  0a  3c  2f  42  4f  44  59  3e  3c  2f  48  54  ESS>.</BODY></HT
000005d0:  4d  4c  3e  0a                                                  ML>.
Re: I keep getting a message, "Bad Request". WiiKid360 3/17/09 6:00 PM
I don't know if this will help, but here is a bad request I just got.

Bad Request

Your browser sent a request that this server could not understand.
Request header field is missing ':' separator.
Acc
Apache/2.0.63 (Unix) mod_ssl/2.0.63 OpenSSL/0.9.8e-fips-rhel5 mod_bwlimited/1.4 PHP/5.2.8 Server at soul-arena.com Port 80
Re: I keep getting a message, "Bad Request". agl 3/17/09 6:00 PM
Thanks.

* Do you know about OSSProxy? Is it something installed on your computer?
* Can you do the tracert bit I mentioned? I'd like to see what ISPs you are going though.
* In chrome, can you click on the Wrench, then "Clear Browsing Data" and check only "Empty the cache" (unless you want to loose your history etc) and click to clear? Afterwards, confirm if current.com is still broken.
Re: I keep getting a message, "Bad Request". WiiKid360 3/17/09 6:06 PM
1- I don't think I have OSSProxy

2- I can't paste the tracert bit here. It times out after a few milliseconds.

3- I cleared it, and it still doesn't work.
Re: I keep getting a message, "Bad Request". WiiKid360 3/17/09 6:07 PM
It said the site times out, not the tracert bit.
Re: I keep getting a message, "Bad Request". agl 3/17/09 6:12 PM
From the view-cache information, it's clear that Chrome's requests are going though something called OSSProxy. It's not running on current.com, I'm guess that it's running on your computer. A quick websearch shows that it's a known bit of adware/spyware. I think that's your problem; it's screwing up Chrome's requests.

I recommend that you try running some adware removal programs. At this point, my knowledge runs out I'm afraid. I know Microsoft do one called "Defender" (for free I think). Might be worth a shot.
Re: I keep getting a message, "Bad Request". WiiKid360 3/17/09 6:13 PM
Ok I'll run something to check.
Re: I keep getting a message, "Bad Request". WiiKid360 3/17/09 6:29 PM
I checked, and I don't have that.
Re: I keep getting a message, "Bad Request". agl 3/17/09 6:33 PM
That OSSProxy line in the reply is coming from somewhere. It's probably your computer, although if you route your traffic via another computer (e.g. a proxy, or via IP forwarding), it could be on there. If you have a home router, you can often get it to as "http://192.168.1.1" (or some such, it varies). If you can get that to webpage, load it in Chrome and goto "view-cache:" again. Find the cache page for "http://192.168.1.1" and see if the OSSProxy line appears in it. If it does, then it's probably your computer.
Re: I keep getting a message, "Bad Request". Blewby 3/31/09 7:54 AM
I believe I found a fix for this....so far it is working well.
Google Chrome was working awesome...until one day I kept getting Bad Request problems when accessing certain sites. This happened no matter what I did with cleaning out the temp files, computer, or whatever. For 1 week this kept stumping me and I found nothing in the forums for help.

Today...I went to my Advanced System Care settings and UNBLOCKED all sites and advertisements it felt "needed to be blocked" (I am sure Spybot Immunizing is the same). I then rebooted the computer and I can access all sites I could not access with Google Chrome before, (it would go to some...but Bad Request on others). I then went back and Immunized all the sites again to see if I could "recreate" the issue and rebooted. Upon reboot I can still access EVERY site that showed a "Bad Request" previously.

I hope this helps
Re: I keep getting a message, "Bad Request". xdancer 4/10/09 12:46 PM
i had that opinion square crap on my computer and when i killed it ALL of my sites on chrome returned with full graphix and everything. so the OSS proxy thing sounds right -- will run ad aware on my drive later --
Re: I keep getting a message, "Bad Request". skatardrummer 4/20/09 8:34 PM
I tried Blewby's suggestion and it didn't work for me. The only site running correctly now is facebook. I had Spybot S&D and just uninstalled it to see what that would do.

deviantart.com is still not loading anything other than text and links.
my.emich.edu says "Bad request. Your browser sent a query this server could not understand."
mail.yahoo.com says "Sorry, Bad Request. Your browser sent a request that this server could not understand.
Request header field is missing colon separator. ‡\àŠPDv±íÍ¡¬–à(
Please check the URL for proper spelling and capitalization. If you're having trouble locating a destination on Yahoo!, try visiting the Yahoo! home page or look through a list of Yahoo!'s online services. Also, you may find what you're looking for if you try searching below."

I've cleared the cache and run CCleaner to make sure nothing was missed. I have Windows Defender, Avira, AVG Free, and spyware blaster. None of them detect any system problems as far as viruses or spyware. Firefox and IE both run normally with no problems on any websites. This is specifically a Chrome issue.

Any other ideas?
Re: I keep getting a message, "Bad Request". WiiKid360 4/21/09 3:22 AM
@skatardrummer I have the same problems as you. No virus protection I have is detecting anything wrong. It is maybe an error with Google Chrome.
Re: I keep getting a message, "Bad Request". AgentLym 5/1/09 6:29 PM
Well, I found out two programs that mess up Chrome:

1)  Relevant Knowledge
2)  Premier Opinion

Those are just two I've found that are found in Program Files, and run when you boot up your computer. :P  Hope that helps!
Re: I keep getting a message, "Bad Request". Samuel.. 8/8/09 9:55 AM
@Blewby

How do I unblock the sites?
Re: I keep getting a message, "Bad Request". Hacker_X 8/17/09 3:40 PM
Hey if your looking for virus removal tool on Windows RUN> mrt.exe and scan for a throughout process of download AVG Anti-Virus 8.5 at or any other Anti-Virus Software:
1. http://www.avg.com/download-file-stb-triais
2. http://us.mcafee.com/root/downloads.asp?id=freeTrials
3. http://download.cnet.com/3001-8022_4-10804572.html?spi=f857a9409119d0cb8088033415ea2906&part=dl-10804572
Re: I keep getting a message, "Bad Request". Hacker_X 8/17/09 3:41 PM
of Windows
Re: I keep getting a message, "Bad Request". classicfm 10/25/09 10:51 AM
I had previously posted a problem with sites loading in chrome, or not as the case may be, kept having to hid reload to get anything loaded. I have started up "Advanced SystemCare Free" and restored back the changes that the spyware removal did. Also decided not to accept it's recommendation on cookies. Not even an XP reboot and bingo, it's all ok again!
Re: I keep getting a message, "Bad Request". grexe 12/9/09 8:36 AM
I encounter the same problem ("Your browser sent a message this server could not understand."), but the same site is working fine in IE and Firefox, both use the same Proxy (settings).

I always get the error when visiting long links as found in newsletters, e.g.:
http://ehg-techtarget.hitbox.com/redirector?hb=DM5212204PCA83EN3;DM550320L1AE83EN3&n=1243984116_467&cd=1&vcon=/bitpipe/bizcard/lead/;/bitpipe/BP/bpmd/bizcard/lead/&hec=0&vjs=HBX0201R&target=http://media.techtarget.com/Syndication/APP_DEVELOPMENT/UnderstandingtheBusinessBenefitsofSOA.pdf&cv.c1=EM|BRU-bpmd-10231238-1243984116_467

Maybe there is a problem with Chrome when trying to handle long URIs?
Re: I keep getting a message, "Bad Request". grexe 12/14/09 3:58 AM
Just happened again with a short URL:
http://blogs.msdn.com/microsoft_press/archive/2009/12/09/free-e-book-first-look-microsoft-office-2010.aspx

The link was followed from this site:
http://www.smart-max.de/aktuell/kostenloses-e-book-first-look-microsoft-office-2010/

When trying again, the second time it worked(!)

Maybe it's the work proxy - I never encountered this problem from home iirc - we use an ancient Netscape Proxy here...
Re: I keep getting a message, "Bad Request". grexe 12/14/09 4:00 AM
The proxy in question is the "iPlanet-Web-Proxy-Server/3.6".
Re: I keep getting a message, "Bad Request". mawjj 12/25/09 7:23 AM
I REPORTED THE BAD REQUEST PROBLEM AND WAS TOLD MY CHROME WAS CORRUPTED AND TO REINSTALL. I DID, AND IMMEDIATELY GOT THE FOLLOWING ERROR. ANY NEW SUGGESTIONS?

Bad Request

Your browser sent a request that this server could not understand.
Size of a request header field exceeds server limit.
Cookie: MNYTSSID=iV8xuq0BSWlv0R2WiF0x; RMID=073417523ed24a53dfb30cd0; up=977NoM1e20SA07hM; TID=00g3iga152l326; NYT_W2=BrooklynNYUS|ChicagoILUS|London--UK|Los%20AngelesCAUS|San%20FranciscoCAUS|Tokyo--JP|; NYT-Recognize=1jaWqcrVgpTKWOymWqECWKQHIlxZ7/8dAzHeRqtrKi/uQQXQ6a/GG3wAA; __utmz=69104142.1247052299.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none); zGT=98DWWWWW2AA1; s_pers=%20s_vsn_nytimesglobal_1%3D3055960796773%7C1565727148844%3B; TData=; __qca=P0-590539380-1255225462887; zFN=9CFz9CDg9CCW9C949B7I09C2P49B0I19A0B2983hL090A70k; zFD=9CFz9CDg9CCW9C949B7I09C2P49B0I19A0B2983hL090A70k; zFN=9CG19CFz9CDg9CCW9C9409C2Q59B0I19A0B2983hL090A80l; zFD=9CG19CFz9CDg9CCW9C9409C2Q59B0I19A0B2983hL090A80l; zFN=9CG29CFz9CDg9CCW9C9409C2R59B0I19A0B2983hL090A90l; zFD=9CG29CFz9CDg9CCW9C9409C2R59B0I19A0B2983hL090A90l; zFN=9CG39CFz9CDg9CCW9C9409C2S59B0I19A0B2983hL090AA0l; zFD=9CG39CFz9CDg9CCW9C9409C2S59B0I19A0B2983hL090AA0l; zFN=9CG49CFz9CDg9CCW9C9409C2T59B0I19A0B2983hL090AB0l; zFD=
Re: I keep getting a message, "Bad Request". tmar23 12/27/09 11:29 AM
Over the past few days I've been hit with a lot of connection failures.  This only happens on Chrome and not IE, Safari, Firefox when trying to access the same sites.  Some times it will even start to load the page before giving the error.  Several refreshes will normally allow you in.  When I disable the "Show suggestions for navigation errors" in options it give me a "Error 102 (net::ERR_CONNECTION_REFUSED): Unknown error.".  This is only happening on one of my computers but there wasn't been anything updated or installed in weeks.  I've tried clearing browser data and a reinstall to no avail.
Re: I keep getting a message, "Bad Request". Mugwort 2/19/10 1:57 PM
Any time I click on a one-line ad over the top line of gmail buttons (e.g, Archive), I always get a "Page not found - connection failure" error from Chrome (version 4.0.249.89 unknown (38071)). This has happened for roughly 30 out of 30 ads, over a period of months.
The error does not come up for Web clips, just for ads (pagead2.googlesyndication.com). I've tried repeated F5 refreshes on this latest example; no change.

An example from today: text "Drain & Sewer Contractors - www.DexKnows.com - Seattle drain & sewer contractors. Find local businesses", link is http://pagead2.googlesyndication.com/aclk?sa=l&ai=B5Yityvt-S_r-N5fAjQS5keSMCbSkwIsBuqy8kQrAjbcBwP-OAhABGAEgho-AAjgAUPPK_439_____wFgyb63jfSk0BmyAQ9tYWlsLmdvb2dsZS5jb226AQhnbWFpbC1jdsgBAdoBMmh0dHA6Ly9tYWlsLmdvb2dsZS5jb20vTVRNeU9ERXpPRFF6TnprM01ETXdPREUyTmpJyAKumrsMqAMB6AOeAegDDOgDE_UDAgAAhA&num=1&sig=AGiWqtzrZ433wNEL2DuGJ06vGvj1HHmzzQ&adurl=http://www.DexKnows.com/rd%3Fdku%3Dhttp%253A%252F%252Fwww%252EDexKnows%252Ecom%252Flocal%252Fconstruction%252Fcontractors%252Fsewers%255Fand%255Fdrains%252Fgeo%252Fc%252Dseattle%252Dwa%252f%26mkt%3D62001%26mkw%3Dc%255Fseattle%2520sewer%2520and%2520drain%2520contractors%255F2623172974

What can I do to help diagnose?

Running Windows XP, updates current.
Re: I keep getting a message, "Bad Request". straight4ward 3/12/10 1:46 PM
Everybody on Win 7 32/64 with the same issues can join us in this thread
 
http://www.google.com/support/forum/p/Chrome/thread?tid=508786b079d788ff&hl=en

and hopefully somebody from Chrome developers will respond!! :(
Re: I keep getting a message, "Bad Request". bobtxt 7/1/10 4:34 AM
Hi,
    Finally it worked, after I deleted the cookies & passwords for that site. These Cookies can be deleted by opening the Menu Developer-> JavaScript Console-> Storage-> New Console. Then it lists the passwords, right click the cookie and delete it.
Re: I keep getting a message, "Bad Request". RobertNewYork 7/29/10 8:40 AM
I have just recently installed Google Chrome, and have been inundated with the bad request 400 errors, I can use Firefox, or even IE, and they can access the very same page that Chrome says is BAD, I am at my wits end, I hated using IE and was so hoping the Chrome would be a great tool, all that is is, is a waste of time, it crashes all the time, restarts, send bad request msgs and has taken the fun out what I expected to be a fun tool, IGoogle home page is great, nifty gadgets that allow for a never ending amount of information being displayed, but, this Bad Request 400 stuff is killing me. So, what does Google blame for this problem? can't be themselves, and I'd love to know why, all my other browser work when Chrome FAILS....

Any Fixes out there for this?
Re: I keep getting a message, "Bad Request". EvelynB 5/5/11 2:41 PM
I have a site I go to often.

For the last week I can't access it on chrome. I get
This web page is not available
The web page at http://feedback.reliefweb.int/reliefweb might be temporarily down or it may have moved permanently to a new web address.
Error 103 (net::ERR_CONNECTION_ABORTED): Unknown error.

I get the same message when trying from google search as when following a link from an email.

But on firefox ..... no problem!

can anyone help?
Re: I keep getting a message, "Bad Request". vdash 5/16/11 3:36 PM
I'm a mac user and I go to ww.investopedia.com and I am redirected with a page saying "Bad Request". When I go onto Firefox, I have no problems going through the website.

Hopefully, there will be an update that fixes this bug.
Re: I keep getting a message, "Bad Request". SafeSki 5/17/11 9:56 PM
Oops! Google Chrome could not connect to zool.imperialviolet.org:4545
Suggestions:
Try reloading: zool.­imperialviolet.­org:­4545
Search on Google:
Re: I keep getting a message, "Bad Request". NHLMetalhead 6/11/11 9:39 AM
I've been getting the Bad Request - headers too long errors on Xbox.com and anything associated with xbox.com (rewards site, etc.) Of course Firefox, IE9 have no issues - no one has been able to solve this problem yet and typical stuff isn't working (cache and cookie clearing) It's stupid and makes no sense to me. I just switched back to FF for good - too annoying to deal with on chrome.
Re: I keep getting a message, "Bad Request". mrsjanc 6/20/11 1:13 PM
This thread show's as 'Answered' but i can't for the life of me find any answer among this lot, seems to me folk are still having this problem, i know i am.
Everything was working fine, had no issues with chrome at all, worked like a dream, then all of a sudden out of the blue all these error messages started to appear, computer's been scanned and cleaned, cache cleared and still i keep getting them...am i missing something here?...where is the answer to this problem?
Re: I keep getting a message, "Bad Request". agl 6/20/11 1:18 PM
mrsjanc: These issues aren't debugable without more information I'm afraid.

1. Close all Chrome windows
2. Restart Chrome
3. Get a "Bad Request" error as simply as possible.
4. Navigate to chrome://net-internals
5. Press the "Dump to Text" button
6. Copy the resulting text into WordPad, NotePad etc, save as a plain text file and attach it to a bug report on http://crbug.com.

You can post the resulting bug link here and I can take a look.
Re: I keep getting a message, "Bad Request". mrsjanc 6/20/11 1:44 PM
This link http://www.blogger.com/blogger.g?blogID=4711377647970474861#editor/target=post;postID=5730965622677352344
Produced Not Found Error 404
Re: I keep getting a message, "Bad Request". wired420 6/24/11 12:17 PM
http://fukung.net/random
HTTP/1.0
400 Bad Request
Server: AkamaiGHost
Mime-Version: 1.0
Content-Type: text/html
Content-Length: 199
Expires: Fri, 24 Jun 2011 19:10:16 GMT
Date: Fri, 24 Jun 2011 19:10:16 GMT
00000000:  e6  00  00  00  02  00  00  00  d3  24  7d  47  10  05  2e  00  .........$}G....
00000010:  0b  e0  7f  47  10  05  2e  00  b7  00  00  00  48  54  54  50  ...G........HTTP
00000020:  2f  31  2e  30  20  34  30  30  20  42  61  64  20  52  65  71  /1.0 400 Bad Req
00000030:  75  65  73  74  00  53  65  72  76  65  72  3a  20  41  6b  61  uest.Server: Aka
00000040:  6d  61  69  47  48  6f  73  74  00  4d  69  6d  65  2d  56  65  maiGHost.Mime-Ve
00000050:  72  73  69  6f  6e  3a  20  31  2e  30  00  43  6f  6e  74  65  rsion: 1.0.Conte
00000060:  6e  74  2d  54  79  70  65  3a  20  74  65  78  74  2f  68  74  nt-Type: text/ht
00000070:  6d  6c  00  43  6f  6e  74  65  6e  74  2d  4c  65  6e  67  74  ml.Content-Lengt
00000080:  68  3a  20  31  39  39  00  45  78  70  69  72  65  73  3a  20  h: 199.Expires:
00000090:  46  72  69  2c  20  32  34  20  4a  75  6e  20  32  30  31  31  Fri, 24 Jun 2011
000000a0:  20  31  39  3a  31  30  3a  31  36  20  47  4d  54  00  44  61   19:10:16 GMT.Da
000000b0:  74  65  3a  20  46  72  69  2c  20  32  34  20  4a  75  6e  20  te: Fri, 24 Jun
000000c0:  32  30  31  31  20  31  39  3a  31  30  3a  31  36  20  47  4d  2011 19:10:16 GM
000000d0:  54  00  00  00  0d  00  00  00  39  36  2e  31  37  2e  31  34  T.......96.17.14
000000e0:  37  2e  31  36  30  00  00  00  50  00                          7.160...P.
00000000:  3c  48  54  4d  4c  3e  3c  48  45  41  44  3e  0a  3c  54  49  <HTML><HEAD>.<TI
00000010:  54  4c  45  3e  49  6e  76  61  6c  69  64  20  55  52  4c  3c  TLE>Invalid URL<
00000020:  2f  54  49  54  4c  45  3e  0a  3c  2f  48  45  41  44  3e  3c  /TITLE>.</HEAD><
00000030:  42  4f  44  59  3e  0a  3c  48  31  3e  49  6e  76  61  6c  69  BODY>.<H1>Invali
00000040:  64  20  55  52  4c  3c  2f  48  31  3e  0a  54  68  65  20  72  d URL</H1>.The r
00000050:  65  71  75  65  73  74  65  64  20  55  52  4c  20  22  26  23  equested URL "&#
00000060:  34  37  3b  72  61  6e  64  6f  6d  22  2c  20  69  73  20  69  47;random", is i
00000070:  6e  76  61  6c  69  64  2e  3c  70  3e  0a  52  65  66  65  72  nvalid.<p>.Refer
00000080:  65  6e  63  65  26  23  33  32  3b  26  23  33  35  3b  39  26  ence&#32;&#35;9&
00000090:  23  34  36  3b  39  63  39  33  31  31  36  30  26  23  34  36  #46;9c931160&#46
000000a0:  3b  31  33  30  38  39  34  32  36  31  36  26  23  34  36  3b  ;1308942616&#46;
000000b0:  61  64  61  35  32  32  62  0a  3c  2f  42  4f  44  59  3e  3c  ada522b.</BODY><
000000c0:  2f  48  54  4d  4c  3e  0a                                      /HTML>.


I've been getting this from random sites including facebook, myspace, fukung.net, damnlol.com, and many more. It seems to happen randomly and takes between 10 and 30 minutes to eventually solve itself.  The cache dump is above. I'll be downloading a sniffer and watching for the next time it happens.

This is becoming extremely annoying and happens every single day. If we can't resolve it I'll be forced to go back to Firefox 4 (Please don't make me do it. It eats so much memory). It never does it in that browser. So its something specific to Chrome.
Re: I keep getting a message, "Bad Request". wired420 6/24/11 12:30 PM
Forgot to post my version. Chrome Version 12.0.742.100
Re: I keep getting a message, "Bad Request". agl 6/24/11 12:56 PM
wired420: does flushing the cache once it starts happening solve anything?

The odd thing is that your cache dump says that the server is AkamaiGHost, but fukung.net runs nginx and doesn't use Akamai as far as I can see.

There's also the standard information gathering procedure as I gave above:
Re: I keep getting a message, "Bad Request". wired420 6/24/11 1:17 PM
http://tinyurl.com/6fja8ep Is the link to my dump attachment. The issue thread is http://tinyurl.com/6xzgjlh

Its now happening on almost everything I try to goto after clearing my cache files again. I had to try six times just to submit the error. It seems to happen more often during the peak hours of the day after school gets out on the east coast.

Makes me wonder if it happens when it receives an ok from your safe browsing proxy to block reported virus sites.

Anyways bout to load up WireShark and start recording until it happens again. Shouldn't be too long. The ONLY site its NEVER happened on yet is google.com.
Re: I keep getting a message, "Bad Request". wired420 6/24/11 2:15 PM
WireShark full pcap recording of the error happening five times. http://www.liquidskies.net/chrome-error-dump.zip

Since clearing my cache, I can't access twitter at all, and facebook.com redirects me to google.com....

Seems to be getting worse the more digging I do. I've installed Windows 7 x64 as identical as I can to my main install on a virtual machine. Attempting to get it to do it there as well.
Re: I keep getting a message, "Bad Request". wired420 6/24/11 3:16 PM
http://www.liquidskies.net/facebook-error-chrome.jpg Now it thinks google hosts facebook..... I've never seen a piece of software go this berserk.

It seems to always fail directly after grabbing favicon.ico from the site your trying to connect.
Re: I keep getting a message, "Bad Request". wired420 6/24/11 4:22 PM
After testing further I've determined this never happens using the https protocol. I switched to all SSL connections and everything running fine again. Unfortunately some sites don't support this and constantly redirect you back to the non-secure version every time you click on something.

So staying SSL isn't a viable option.
Re: I keep getting a message, "Bad Request". agl 6/27/11 10:45 AM
@wired420: I've looked at your packet dump and net-internals dump and the problem is somewhere external to Chrome.

Chrome is seeing odd DNS resolutions. Sadly your packet dump didn't include any DNS packets, but from the net-internals dump, Chrome is seeing the wrong IP address for twitter.com (and others). Additionally, the fact that HTTPS functions is telling: intercepting middleware can't manipulate HTTPS traffic.

So I believe that something upstream of your Internet connection is broken. It might be trying to transparently intercept and cache HTTP requests, but it's buggy. HTTPS will work because it bypasses the interception.
Re: I keep getting a message, "Bad Request". Nitajk 6/29/11 11:08 PM
I am so disappointed with chrome. I loved it initially but now cannot access my own blog. keep getting the 400 bad request error. I can sign in to my blog from all other browsers. As for the fixes suggested here, for a layperson like me I think it is too confusing and frankly I don't think I should be doing it. The Chrome people should be doing it. For me it is a waste of time. I took a long time to figure out all the solutions suggested here, and decided it was simply not worth it. Chrome is simply not good enough.
Re: I keep getting a message, "Bad Request". PeterSA 7/18/11 4:39 AM
Running Defender did not work. The other post suggesting Clearing Browsing Data worked (Wrench icon/Tools/Clear browsing data, with all default options left on).
Re: I keep getting a message, "Bad Request". Anuj Sogarwal 12/7/11 6:51 AM
Everytime I try to open a website I receive the message "unauthorized request"! But I am able to open open HTTPS website
what can i do for this bloody problem


please someone help me otherwise i will clash the PC..........
More topics »