Categories: Report an Issue :

When launching chrome, the browser does not open

Showing 1-39 of 39 messages
When launching chrome, the browser does not open sr123 1/22/09 10:06 PM
As per topic, on Windows XP SP2 - a process "chrome.exe" appears with the updater in taskmgr, but no browser.
I think I've figured out the problem. This was discussed without solution in the previous Chrome troubleshooting archives at http://groups.google.com/group/google-chrome-help-troubleshooting/browse_thread/thread/cc1c66bfc0485d22
Chrome works well in the past, no hitches, installed via GooglePack and works for all user accounts. Suddenly when trying to open the browser, a screen flashes and disappears and you find yourself with a running "chrome.exe" process, but no browser.
For me, this problem started when I was playing around with security settings in the "Program Files" folder, namely trying to make inheritance more uniform. I quickly found out that this was a stupid thing to do, and tried to revert the changes. This seemed to occur even after logging off windows, though I didn't try a full restart. However, an instant fix was in going to the task manager (ctrl-alt-del) and ending chrome's dependency process, "GoogleUpdater".
What was interesting was that in testing out the problem, GoogleUpdater (opened separately) showed Chrome as not being installed, while other Google products were reading fine. This leads me to think that maybe Chrome is a bit touchy as to its permissions in XP.
I haven't tried yet, but I believe this problem can be repeated by, after startup, changing security permissions on the Google folder in "C:\Program Files\Google" and all files and subfolders (or even just the inheritance settings, as I did).
Re: When launching chrome, the browser does not open macweirdo 2/27/09 1:33 PM
This is the same thing happening to me. idk as well. One piece of advice though - check the path that "chrome.exe" is at. Right-click on the shortcut, select Properties. My path was "C:\Documents and Settings\Robert\Local Settings\Application Data\Google\Chrome\Application\chrome.exe" (substitute Robert with your username.)
Re: When launching chrome, the browser does not open fozzi_behr 4/28/09 7:12 AM
My path was C:\Documents and Settings\Nick\Local Settings\Application\chrome.exe, and was working fine until one day when it just stopped opening. I went to the folder, and there were 2 exe's, and I could get neither to open. I did not change any of my settings, as to permissions, and I even tried reinstalling, but that did not work either.
Re: When launching chrome, the browser does not open david.rice.86 4/30/09 7:45 PM
I have tried all of the listed fixes that I can find, and so far my Chrome still will not open when I click on the icons or try and run it directly from its file. Does anyone have any more suggestions?
Re: When launching chrome, the browser does not open esgar 7/23/09 7:43 AM
I have the same issue; what I'm doing right now to open chrome is going to task manager and hit "new task.." enter chrome and it will open...

Hopefully somebody can have a fix..... (I love chrome)
Re: When launching chrome, the browser does not open DeHARcO 9/14/09 1:04 AM
Ver Strange Issue  I Agree. The task manager opens chrome but not the run command. First I went into the options and on the "Under the Hood" tab i clicked restore defaults. After that I changed the shortcut on the desktop. For some reason the shortcut on the desktop's compatibility tab was set to Windows 95 compatibility. I removed that and it suddenly started working again. I also changed the shortcut on the desktop's. I cleared the startin boxes value. Only leaving the target box that links to chrome.exe.
Re: When launching chrome, the browser does not open sirviejo 2/7/10 6:14 AM
I solved this issue with macweird's tip. It seems that some kind of virus or malware changes my shortcut's destination. I edit that and solved issue.
Re: When launching chrome, the browser does not open zerowx5 7/27/10 7:05 AM
i found this a simple solution. search google chrome in windows then find the actual .exe double click it and it will open right? something might have happened to the shortcut so just basically create a new shortcut and tada it works again dont ask me why but i dunno why chrome does this its a minor and simple issue im sure google should attend to.
Re: When launching chrome, the browser does not open oneStarman 8/5/10 7:27 AM
I have been having this problem with Chrome Process(es) also.  Multiple chrome process in Task Manager with only Google home page running. Then when I close the browser the Chrome process is still running and my Hard Drive is being hammered. It seems to getting worse.  I think the problem began after installing then un-installing google desktop. Its 'Indexing' function caused explorer to hang.  Now after un-install explorer sometimes STILL hangs.
Re: When launching chrome, the browser does not open thinkbrinke 8/5/10 8:16 AM
I have noticed that in the last few days..Chrome is SLOW to start in the AM.  to the point that iGoogle gave me an AW SNAP this page is not responding.
Re: When launching chrome, the browser does not open SCSteiner 8/15/10 7:25 PM
My chrome stopped loading.  After firing the application I would look in task manager and it was not there.  I simply downloaded and installed the current version and it now WORKS.  I did not even have to reboot.
Re: When launching chrome, the browser does not open Momekh 12/27/10 12:11 AM
You could solve this problem by perhaps doing what I did:
I downloaded and installed Google Chrome (via FF). It started connecting to the Net to d/l Chrome files etc, and when that finished, my previous Chrome just fired up, asking me if I wanted to restore to the last time Chrome... hells yeaah! Bookmarks intact and everything.
Hope this helped.
Re: When launching chrome, the browser does not open angiekae68 3/13/11 1:33 PM
I've tried all the fixes, still nothing. When I opened the Task Manager, went to "New Task" and typed in "Chrome", the process actually appeared in the Task Manager, but then disappeared a few seconds later. No clue what's going on but I wish someone could figure out how to fix it :(
Re: When launching chrome, the browser does not open Christi6746 3/16/11 10:34 PM
I have tried all these suggestions and other things, too, and NOTHING is working for me.  Safari has the same exact issue.  Only Firefox will work and I HATE Firefox.  I need my chrome back.  :(
Re: When launching chrome, the browser does not open DJ Allyn 3/24/11 3:44 PM
My work computer, an old XP box, was running Chrome fine for months.  Then suddenly, two days ago, Chrome just stopped loading.  I uninstalled with Revo, ran Ccleaner and cleaned up the registry, and reinstalled Chrome and it STILL doesn't load.

Looking in the Task Manager, I can see Chrome.exe appear for a second, then disappear.  I can't seem to get any answers anywhere.  It's like Chrome suddenly became unstable and refuses to work any more.
Re: When launching chrome, the browser does not open marcel.spitz 4/27/11 4:35 PM
A possible reason for this problem we think can be found in the definition of multiple displays. I often use a TV monitor to display and present and I believe that somehow there is a mismatch between what I scan see and what can be used by the system to display

When I start Chrome with the normal icon, it starts and all tabs are loaded and shown in the process tab of the task manager BUT... that Chrome browser instance is no where to be seen on the screen. So I searched for chrome.exe with Windows File Manager in the folders on my C drive.

Then many versions of chrome.exe were shown and I selected the one in this folder:
C:\Users\Marcel\AppData\Local\Google\Chrome\Application  
I was able to start that one and it showed only one narrow strip of the right side so most of it was hidden on the left hand side of my screen.

Sorry, but I have not yet discovered how to find the hidden instance. :-(  but I will report back when I do.

PS Could this be Microsoft or some other clown that is trying to get people to stop using Google Chrome?
Re: When launching chrome, the browser does not open jshpro2 6/18/11 10:06 AM
I have the same setup as marcel spitz with a TV. However I have experienced both 'hidden windows' that can be recovered with alt+tab, and this issue. This issue is different. The window never exists within Windows. The chrome.exe kills itself after a few minutes. I thought Google Chrome was a great browser until this.
Re: When launching chrome, the browser does not open mdayalan 7/30/11 3:06 AM
I'm having the same problem as DJ Allyn. I just got this new Asus laptop. Naturally the first thing I did was install chrome. It launched the first time but then anytime after that, I click and nothing happens. I couldn't even open the uninstaller! I had to use Revo. There seems to be no solution to this problem..
Re: When launching chrome, the browser does not open Mariisaur 8/21/11 2:09 PM
I just recently downloaded Chrome. Its not the first time this happens, but it doesn't open. I've unistall then reinstall and its still the same. I click on it, and nothing happens. I've found out through other sites that I have to create an "exception" for it on my firewall settings, so I did. Yet, nothing happens. I've been using Firefox, and I love it. But I'm just curious about Chrome because it sounds cool. I've tried most things listed here and in other sites, and I get absolutely nothing! Anybody with a similar problem? I need help!
Re: When launching chrome, the browser does not open DJ Allyn 8/21/11 4:27 PM
Apparently, given the fact that this is an issue that has been going on for YEARS now, nobody seems to have an answer to it.  

My work computer has nothing different on it than any of the other work stations in the office, it is just that Chrome doesn't like this particular machine for no apparent reason.
Re: When launching chrome, the browser does not open hunain124 9/20/11 12:45 AM
My google chrome is not working at all, neither I am able to reinstall it...all the other browsers are working fine...
Re: When launching chrome, the browser does not open DJ Allyn 9/20/11 8:38 AM
Nobody from Google seems to care.  For that reason alone, I am just giving up on them and sticking with Firefox.  There is no point for having a "Google Forum" like this is nobody is paying attention.
Re: When launching chrome, the browser does not open playflpup 9/21/11 12:11 AM
I did what Momekh did and it brought everything back to the way it's supposed to be!
Re: When launching chrome, the browser does not open DJ Allyn 9/21/11 9:41 AM
I've tried that playflpup.  Several times.  I'm glad it worked for you, but it still hasn't worked for me.
Re: When launching chrome, the browser does not open rosskenn 10/25/11 2:29 PM
I am with DJ Allyn.
Exactly same problem.
Two computers;  main one with exactly same security set up as second computer.
Second computer will download google chrome, and it works.
Main computer will download google chrome, but will not open brower window.

Cant be that difficult to fix.
Re: When launching chrome, the browser does not open DJ Allyn 10/25/11 4:56 PM
Complete formatting and reinstall on my computer and Chrome now runs.
Re: When launching chrome, the browser does not open M115 11/28/11 10:16 PM
make sure that you have another search standing by remove google chrome first, to where it is located, i mean delete it..all the shortcuts, at your desktop, then go to your program features, uninstall it, it will say that cannot find the path, then it will ask do you want to remove it anyway? say yes..everything must be deleted about google chrome take note . then open another browser and try re-installing again.
Re: When launching chrome, the browser does not open Charan Mandya 12/8/11 12:45 AM
I too faced the same problem and fixed by scanning 'Registry' folder.(I'm using Windows 7 OS)
Right click on McAfee icon in tray, Select 'Scan My Computer For' ->Threats-> Select 'Registry' in the List-> Click 'Start' button.
Re: When launching chrome, the browser does not open kewlkeifer 2/25/12 4:35 PM
Uninstall chrome, shut down computer (clears data) then re-install.
Re: When launching chrome, the browser does not open AsusRocks 4/20/12 12:13 AM
Hi All
I have a new Asus laptop as well and experiencing the same problem. No matter what I do it jumps up for a few seconds and then dissapears.
Is it maybe something that Asus loads on their machines?

Re: When launching chrome, the browser does not open turtoise 4/26/12 8:17 AM
Hello All,
I had the same issue and solved it by Uninstalling Chrome with Revo and deleting C:\Documents and Settings\%USERNAME%\Local Settings\Application Data\Google
folder. After this I installed Chrome successfully and it works.
Re: When launching chrome, the browser does not open Fredrich VonStuvenhausin III 5/11/12 1:31 AM
I personally have not had this issue, the missus has on her laptop though. The only fix i could come up for it is right click your shortcut and select run as, or run as administrator on windows 7. In xp it's just run as though, a box will pop up and select run as this user and type in the administrator user name and password. Even if you are logged in as administrator.
Re: When launching chrome, the browser does not open HAVEANICEDAY72 7/11/12 10:45 PM
I WAS ABLE TO FIX BY RIGHT CLICKING ON CHROME.EXE AND CLICKING ON THE COMPATABILITY TAB.  RUN IN WINDOWS XP SERVICE PACK 3 COMPATABILITY MODE.  HOPE IT WORKS FOR YOU.
Re: When launching chrome, the browser does not open starsia 8/11/12 12:31 AM
Allow or disable site handler requests

By default, web services are allowed to show messages about protocol links when you visit their sites. To disable or re-enable these messages in Chrome, follow the steps below.

Click the wrench icon  on the browser toolbar.
Select Settings > click Show advanced settings.
In the "Privacy" section, click Content settings.
In the dialog that appears, find the “Handlers” section:
To allow requests, select “Allow sites to ask to become default handlers for protocols.”
To disable requests, select “Do not allow any site to handle protocols.”
Choose a default handler or remove a handler

Use the Settings page to manage the web services you’ve allowed to act as handlers.
starsia 8/11/12 12:31 AM <This message has been deleted.>
Celso S. 7/4/13 10:24 AM <This message has been deleted.>
Re: When launching chrome, the browser does not open Celso S. 7/4/13 10:25 AM
You can access Chrome again on 4 steps:
1 -create new Windows account/user as administrator.
2 -Log out / chance user
3 -Access new  User account
4 -Enjoy Chrome!
Re: When launching chrome, the browser does not open fbanurag 7/7/13 9:20 AM
After a lots of tweaks I came up with this WORKING Solution. It's a shame that Google never came up with a solution. I no more use your search engine because Bing is better than yours now!

Solution:
1. Create a shortcut of Chrome by Going to C:\Users\(Your Username)\AppData\Local\Google\Chrome\Application
2. Right click on Chrome.exe and create a desktop shortcut.
3. Goto desktop, right click on Chrome Shortcut and select properties.
4. Goto "Security" Tab and click on "Advance" button
5. Under "Owner" section click on "Change" button.
6. In the box type in your User name and press Enter
7. Goto "Effective Access" Tab and select "Select a user"
8. Type in your User name again in the box and hit "Enter"
9. Click Apply, OK.
10. Again Apply, Ok.

Enjoy!

This is with respect to Windows 8/Blue. Same for Previous OS.

Use BING

Re: When launching chrome, the browser does not open Kenny Vo 7/9/13 9:14 PM
Alright. I heard the other solutions on how to fix it. I restarted, i restarted the pins and shortcuts, I re-installed, and everything else I can think of, but it opens once and it never works again. It seems that the Processes are still running, but I ended all of the process trees, and it still doesn't work. SOMEONE HELP ME!!!!
More topics »